samba e winbind

2 risposte [Ultimo contenuto]
Ritratto di Tyrel
Tyrel
(Junior)
Offline
Junior
Iscritto: 11/09/2004
Messaggi: 7

Salve a tutti,
io ho un problemone con samba e winbind.
Spiego meglio: ho un server window 2k che fa da domain controller e quindi ho active directory con i vari users, a questo punto ho deciso di inserire un server linux e mi serve far joinare il server linux al dominio e che questo mi prenda i vari users da active directory. Leggendo in giro ho saputo di winbind e l'ho installato e ho configurato tutto, ma non mi funziona perchè ogni volta sputtano l'active directory ora vi do in dettaglio i vari file che ho configurato.

SMB.CONF

[global]
workgroup = INFONET
netbios name = CARAMON
log file = /var/log/samba/log.%m
max log size = 1000
invalid users = root
security = DOMAIN
password server = *
winbind separator = +
winbind uid = 10000-20000
winbind gid = 10000-20000
winbind enum users = Yes
winbind enum group = Yes
winbind use default domain = Yes

[infonet]
comment = Dati
path = /infonet
browseable = Yes
writable = Yes

SYSTEM-AUTH

auth required /lib/security/pam_env.so
auth sufficient /lib/security/pam_winbind.so
auth sufficient /lib/security/pam_unix.so likeauth nullok use_first_pass
auth required /lib/security/pam_deny.so

account sufficient /lib/security/pam_winbind.so
account required /lib/security/pam_unix.so

password required /lib/security/pam_cracklib.so retry=3
password sufficient /lib/security/pam_unix.so nullok use_authtok md5 shadow
password required /lib/security/pam_deny.so

session required /lib/security/pam_mkhomedir.so skel=/etc/skel/ umask=0022
session required /lib/security/pam_limits.so
session required /lib/security/pam_unix.so

NSSWITCH:CONF

passwd: files winbind
group: files winbind
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

poi fatto questo digito:
net join -S CARAMON -U Administrator

li mi fa il join al dominio ma mi da dei errori. Eseguendo wbinfo- g e -u vedo sai i gruppi e utenti, eseguendo getent passwd e getent groups mi da i vari id. Dopodichè guardo il mio server e l'active directory si sputtana.
Qualcuno che abbia già affrontato questo argomento?
Qualche idea?

Ritratto di giuliano
giuliano
(Newbie)
Offline
Newbie
Iscritto: 18/03/2005
Messaggi: 5

Ciao,
non sono un esperto di samba ma qualche mese fa ho inserito
il mio PC con linux nel dominio della azienda per cui lavoro. Per
farlo non ho fatto altro che seguire passo passo le istruzioni di
"Samba-3 by example", una guida compresa nel pacchetto
samba-doc. In particolare quello che ti serve leggere è il capitolo 9,
paragrafo "Active Directory Domain with Samba Domain Member
Server"

Riguardo al tuo smb.conf ho notato che hai "Security = Domain"
mentre dovrebbe essere "Security = ADS", inoltre anche il comando
che ho usato per fare il join al dominio è diverso: net ads join ...

Ciao.

Ritratto di Tyrel
Tyrel
(Junior)
Offline
Junior
Iscritto: 11/09/2004
Messaggi: 7

Ciao, grazie per l'aiuto, ora diciamo che ho altri problemi, ho seguito passo a passo le istruzioni su samba.org, pero lo stesso il computer non mi joina 'active directory, am almeno questa volta non l'ho sputtanata, quando faccio net ads join -I ip -U user%pass
mi da la parola terminated dopo che il computer lavora per parecchio. Nel file syslog mi da errore dicendo out of memory killed process.
Qualcuno mi sa aiutare?
Grazie!