disconnessione apparente al cambio utente

3 risposte [Ultimo contenuto]
Ritratto di SuperPisu
SuperPisu
(Monster)
Offline
Monster
Iscritto: 06/11/2004
Messaggi: 228

vorrei far notare la rima del titolo 8-)

allora ho un problema molto particolare nella mia sarge che ho installata nel fisso :

premetto che sono dietro a un router

il problema è che quando mi loggo con un utente (uso gdm) tutto ok ma se per caso esco dalla sessione e torno nel gdm a quel punto e come se non fossi piu connesso ...

ho fatto parecchie prove ma l'unico modo per essere riconnesso è riavviare la macchina

infatti con ifconfig non sembrano esserci problemi l'indirizzo rimane e anche se provo a rifare dhclient e buttare giu l'interfaccia di rete non risolvo nulla

altra cosa la connessione cade anche nella lan interna infatti non posso nemmeno connettermi al router oltre che a qualsiasi pc collegato

aggiungo che con il mio portatile sempre con debian non ho questo problema e ciò mi fa cadere il dito su problemi software del fisso..

qualche aiuto o consiglio ???

grazie Wink

8-) Superpisu 8-)

(10:47:50) chars: mi sposo
(10:48:07) chars: ho trovato l'amore
 
(17:47:09) chars: ai tempi d'oro
(17:47:19) chars: quando ero uno street boy

Ritratto di SuperPisu
SuperPisu
(Monster)
Offline
Monster
Iscritto: 06/11/2004
Messaggi: 228

dovrei aver trovato l'errore

infatti nel dmesg mi dice

NETDEV WATCHDOG: eth0: transmit timed out

ma non riesco ancra a venirne a capo

Sad

8-) Superpisu 8-)

(10:47:50) chars: mi sposo
(10:48:07) chars: ho trovato l'amore
 
(17:47:09) chars: ai tempi d'oro
(17:47:19) chars: quando ero uno street boy

Ritratto di darkbrua
darkbrua
(Geek)
Offline
Geek
Iscritto: 06/10/2004
Messaggi: 131

Molto probabilmente devi fare il boot appendendo l'opzione noapic (es: append='noapic' per il lilo.conf)

Fa sapere Wink

darkbrua - Debian GNU/Linux 'unstable' - kernel 2.6.11-ck7
Linux Registred User #338336 - Machine #227762

Ritratto di SuperPisu
SuperPisu
(Monster)
Offline
Monster
Iscritto: 06/11/2004
Messaggi: 228

avevo visto anche io ma ora sto provando un'
altra strada infatti mi sono accorto che nel kernel del portatile, dove il problema non si presenta, è disabilitato il timer watchdog mentre era abilitato nel fisso.

quindi sto ricompilando..

sperem

Big Grin

8-) Superpisu 8-)

(10:47:50) chars: mi sposo
(10:48:07) chars: ho trovato l'amore
 
(17:47:09) chars: ai tempi d'oro
(17:47:19) chars: quando ero uno street boy