Problemi con apt-get e router

7 risposte [Ultimo contenuto]
Ritratto di iacchi
iacchi
(Newbie)
Offline
Newbie
Iscritto: 03/03/2005
Messaggi: 5

Ciao a tutti,
mi trovo a scrivere qui sperando che possiate risolvere il mio problema dopo aver già postato in 3 forum diversi e 2 mailing list senza risultato Sad

Veniamo al dunque: sono connesso a internet tramite un router con modem adsl integrato. Funziona tutto benissimo, tranne apt (o synaptic) che non riesce a contattare i repository. Non capisco cosa possa essere perché, come ho detto, tutto il resto funziona alla grande.

Per darvi un'idea di cosa ho già sperimentato, vi do i link alle discussioni sugli altri due forum dove ho avuto risposta:

http://forum.html.it/forum/showthread.php?s=&threadid=789733

http://www.debian-italia.com/forum/viewtopic.php?t=71

ringrazio chiunque riesca a venire a capo del problema.

Ritratto di gad79
gad79
(Geek)
Offline
Geek
Iscritto: 25/12/2004
Messaggi: 103

Non so se potrebbe eserti di aiuto , ma ha me mi e successo un cosa simile alcune settimane fà.
Praticamente il server dns impostato da me non faceva il resolv del ip in modo coretto. ( porobabilmente non è aggiornato .. o ho sbagliato io a indicare l'indirizzo ???) Quindi verifica nel file /etc/resolv.conf se l'indirizzo è quello giusto o magari scegline un'altro di server.

Ciao

Ritratto di iacchi
iacchi
(Newbie)
Offline
Newbie
Iscritto: 03/03/2005
Messaggi: 5

Scusa la mia niubbaggine, ma credo di non aver capito bene.

Qual è il DNS che non va bene? Quello che corrisponde all'IP del router o quello dell'ISP (che non credo tra l'altro di avere impostato)? Se è quello del router, posso assicurarti che è corretto.

Ritratto di gad79
gad79
(Geek)
Offline
Geek
Iscritto: 25/12/2004
Messaggi: 103

Vai a vedere il file /etc/resolv.conf , dovresti vedere una scritta del tipo:

nameserver xxx.xxx.xxx.xxx

prova a modificare l'indirizzo e metterne uno nuovo tipo questo che ti riporto qua sotto.

nameserver 151.99.125.2

poi dimmi se va.

Ciao

Ritratto di iacchi
iacchi
(Newbie)
Offline
Newbie
Iscritto: 03/03/2005
Messaggi: 5

niente da fare. Comunque, a chi interessa, questo è il mio resolv.conf:

nameserver 192.168.1.1
nameserver 139.175.55.224
nameserver 151.99.125.2

anche se credo che l'ultima voce sia inutile.

Ritratto di gad79
gad79
(Geek)
Offline
Geek
Iscritto: 25/12/2004
Messaggi: 103

Scusami per fare un' ultima prova, meti quella voce al primo posto e dimi quali nameserver hai impostato sul router.

Ritratto di iacchi
iacchi
(Newbie)
Offline
Newbie
Iscritto: 03/03/2005
Messaggi: 5

Mettendolo primo della lista va!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Verrei a darti un bacio se non fossi distante e avessi la certezza che sei un nuomo!

Ma che cavolo di DNS è quello?

Ritratto di gad79
gad79
(Geek)
Offline
Geek
Iscritto: 25/12/2004
Messaggi: 103

An vedi . Sono una ragazza cmq !! Laughing [skerzo ]
Cmq quando ho avuto questo problema anch'io non ci volevo credere ...

Ciao . :-P , alla prossima !!