compilare programmi qt

7 risposte [Ultimo contenuto]
Ritratto di comick
comick
(Junior)
Offline
Junior
Iscritto: 23/12/2004
Messaggi: 40

Ho problemi a compilare i programmi che usino librerie qt.

Infatti mancano gli headers qt.

Allora ho scomodato apt e ho visto che libqt3-dev è già installato. Al che non capisco quale pacchetto installare.

Che mi dite? Grazie Smile

PlayLINUX.net - la comunità italiana interamente dedicata ai videogiocatori del pinguino!

Ritratto di syneus
syneus
(Junior)
Offline
Junior
Iscritto: 17/09/2004
Messaggi: 16

Un semplice 'apt-cache search libqt header' dice
libqt3-headers - Qt3 header files

presumo che tu debba installare questo pacchetto.

Ritratto di comick
comick
(Junior)
Offline
Junior
Iscritto: 23/12/2004
Messaggi: 40

l'avevo già provato, ma:

comick:/home/michele# apt-get install libqt3-headers
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
libqt3-headers gi alla versione pi recente.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
comick:/home/michele#

PlayLINUX.net - la comunità italiana interamente dedicata ai videogiocatori del pinguino!

Ritratto di oufresh
oufresh
(Monster)
Offline
Monster
Iscritto: 08/09/2004
Messaggi: 259

Prova con apt-get install libqt3-mt-dev. oppure potrebbe volerci libqt3-compat-headers, se usi delle chiamate non apparteneti alle API ufficial QT.

Ritratto di comick
comick
(Junior)
Offline
Junior
Iscritto: 23/12/2004
Messaggi: 40

mmm nulla. vi dico quello che cerco di compilare:

openc6.sf.net

PlayLINUX.net - la comunità italiana interamente dedicata ai videogiocatori del pinguino!

Ritratto di OldSparky
OldSparky
(Geek)
Offline
Geek
Iscritto: 07/01/2005
Messaggi: 158

Penso ti servino gli header per le lib Qt2, ma da quello che ho visto esistono solo per la versione 3.

Deve esserci un modo pero' per fare usare al programma la ver. 3 nel caso fossero retrocompatibili.

Ritratto di oufresh
oufresh
(Monster)
Offline
Monster
Iscritto: 08/09/2004
Messaggi: 259

In liqt-compat-headers dovrebbero esserci gli headers per le vecchie qt ma non sono molto sicuro della retrocompatibilità.

Ritratto di comick
comick
(Junior)
Offline
Junior
Iscritto: 23/12/2004
Messaggi: 40

ma non usa le qt2 quel programma.

PlayLINUX.net - la comunità italiana interamente dedicata ai videogiocatori del pinguino!