Problemi dopo installazione Debian 7 Wheezy (distro per applicazione speciale)

4 risposte [Ultimo contenuto]
Ritratto di as2
as2
(Newbie)
Offline
Newbie
Iscritto: 21/10/2019
Messaggi: 4

Problemi dopo installazione Debian 7 Wheezy

sito linuxcnc.org

LinuxCNC 2.7.14 Debian 7 Wheezy
(http://www.linuxcnc.org/iso/linuxcnc-2.7.14-wheezy.iso)

Ho installato questa distribuzione per creare una macchina a controllo numerico,
più o meno gli stessi problemi li riscontro sia su un pc desktop che su un portatile.

Innanzi tutto l'installazione và a buon fine solo installandola in inglese (dicono che è normale per questa applicazione linuxCnc).

No problem dopo installazione porto in Italiano e invece

Il file manager Thunar 1.2.3 l'ho portato in italiano
# apt-get install locales
# dpkg-reconfigure locales
# reboot

Tutti gli altri programmi sono in inglese e non riesco a cambiare il linguaggio

per esempio il browse Iceweasel
Edit, Preference, Content, Language, seleziono la lingua italiana e la porto in prima fila.
Però rimane sempre in inglese.

Non si riese ad installare i pacchetti .deb con l'applicazione Gestore pacchetti,
clicco due volte sul file, mi chiede la password, si apre l'applicazione e basta non succede niente.
Idem se provo ad aggiornare le informazioni sui pacchetti, aggiorna solo dal server linuxcnc.org.

Se provo ad installardi da terminale ho questo risultato:

xx@yyy:~/Downloads$ sudo dpkg -i synaptic_0.84.6_i386.deb
[sudo] password for xx:
dpkg-deb: errore: l'archivio "synaptic_0.84.6_i386.deb" contiene un elemento dati incomprensibile control.tar.xz, operazione annullata
dpkg: errore nell'elaborare synaptic_0.84.6_i386.deb (--install):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
synaptic_0.84.6_i386.deb
xx@yyy:~/Downloads$

-----------

Installo un pacchetto cad e ottengo lo stesso risultato.

xx@yyy:~/Downloads/Librecad$ sudo dpkg -i librecad_2.1.3-1.2_i386.deb
[sudo] password for xx:
dpkg-deb: errore: l'archivio "librecad_2.1.3-1.2_i386.deb" contiene un elemento dati incomprensibile control.tar.xz, operazione annullata
dpkg: errore nell'elaborare librecad_2.1.3-1.2_i386.deb (--install):
il sottoprocesso dpkg-deb --control ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
librecad_2.1.3-1.2_i386.deb
xx@yyy:~/Downloads/Librecad$

Da terminale sono riuscito solo ad installare il pacchetto AdbeRdr9.5.5-1_i386linux_enu.deb

La distro Wheezy non è più supportata per cui non si può più installare/aggiornare i singoli pacchetti ?
i pacchetti .deb non sono più compatibili con le versioni vecchie ?

Grazie per la collaborazione
Angelo

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1448

Ciao,

Debian Wheezy, come hai osservato, non è più supportato. I pacchetti della distribuzione sono archiviati nel repository delle release non supportate. Pertanto, per usare il gestore dei pacchetti per attingere dai repository di Debian Wheezy, devi configurare il gestore di pacchetti per puntare al repository http://archive.debian.org . E' del tutto evidente che pacchetti di programmi recenti avranno dipendenze che potrebbero essere incompatibili con il pacchetti forniti da Debian Wheezy, fatto salvo tu non provveda in autonomia a compilare le dipendenze mancanti (ma da come scrivi, mi sembra proprio di no). Peraltro, mi sembra di averti già letto per un analogo quesito, forse in questo stesso forum: è così ?

In ogni caso, la distribuzione LinuxCNC, da un breve ricerca, utilizza i suoi repository: hai letto la documentazione all'indirizzo http://www.linuxcnc.org/docs/2.7/html/getting-started/updating-linuxcnc.html

Ritratto di as2
as2
(Newbie)
Offline
Newbie
Iscritto: 21/10/2019
Messaggi: 4

Ciao, si avevo già scritto su questo forum, ma poi ho piantato li il tutto.
Riprendo ora.

Linuxcnc utilizza i suoi repository e funzionano si è aggiornata (l'immagine iso era la 2.7.0).
La versione stabile è la 2.7.15 e si era aggiornata correttamente, poi ha fatto un'altro aggiornamento ed è
passata alla 2.9.0-pre0-g5a8a8e2 è la versione nuova ma va bene.
Tutto quello che riguarda Linuxcnc per me è funzionante al 100%, si è anche aggiornato in italiano.
Per cui da quel lato posso procedere a testare l'applicazione.

Volevo completare l'aggiornamento alla lingua italiane del sistema e installare altri pacchetti.
Non tutti i pacchetti ma i più utilizzati, almeno Iceweasel

Il repository delle release non supportate dove lo trovo?.

Ho notato questo:

Attached images:

Ritratto di as2
as2
(Newbie)
Offline
Newbie
Iscritto: 21/10/2019
Messaggi: 4

Ciao,
ho risolto quasi tutto, dopo parecchi tentativi a continuare a far rileggere l'indirizzo dei repository,
leggeva per esempio 27 di 84 e si fermava, riprovavo e indicava 34 di 72 e cosi via.
Ho inserito di nuovo l'indirizzo "deb http://archive.debian.org/debian wheezy main".
Continuando a riprovare si è messa a funzionare, ha terminato di scaricare gli indici dei pacchetti.
Sono riuscito ad installare il software cad che mi interessava e il linguaggio in italiano del browser.

Ora quando accendo il portatile mi compare un messaggio che indica il servizio di rete disabilitato e in modalità Local ??

Sapete cosa sia ?

Grazie
Angelo

Attached images:

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1448

Penso che abbia a che fare con l'installazione di avahi-daemon; prova a disinstallarlo, probabilmente non ti serve.