Dopo l'installazione debian non si avvia

17 risposte [Ultimo contenuto]
Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1448

Scusa la banalità della domanda: hai impostato le casse JBL in "pairing-mode" prima di provare ad effettuare l'accoppiamento con Debian ?

Ritratto di Rox3
Rox3
(Junior)
Offline
Junior
Iscritto: 01/01/2020
Messaggi: 10

La cassa era impostata in "pairing-mode", la connetto senza problemi sia a Windows (sulla stessa macchina) sia ad un Mac.
Ho fatto delle prove anche con un cellulare e ottengo lo stesso risultato.

Grazie,
Rox3.

Ritratto di Rox3
Rox3
(Junior)
Offline
Junior
Iscritto: 01/01/2020
Messaggi: 10

Ho riscontrato anche un altro problema:
ho provato a collegare il mio computer ad un monitor esterno, tramite cavo hdmi-hdmi, ma il risultato è che Debian non lo vede mentre su Windows tutto funziona correttamente. Quindi ho supposto che ci fosse un problema di driver su Debian. Seguendo le istruzioni su https://wiki.debian.org/it/NvidiaGraphicsDrivers ho dato il seguente comando :

$ lspci -nn | egrep -i "3d|display|vga"
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b]
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] [10de:1cbc] (rev a1)

Dall'output avendo due schede grafiche quella Intel e quella discreta Nvidia ho concluso di avere un chipset grafico Optimus (ibrido) e di dover seguire le istruzioni su https://wiki.debian.org/it/Bumblebee e così ho proceduto dando il seguente comando:
# apt-get install bumblebee-nvidia primus

Finita l'istallazione ho riavviato il pc e dopo il menu di grub Debian non riusciva più a partire.
Non mi è ben chiara la relazione tra 'nouveau.modeset=0' (parametro di boot che ho aggiunto permanentemente senza il quale non riesco ad avviare debian) e scheda grafica, ma ho comunque provato a rimuevere il parametro temporaneamente ma non è cambiato nulla. Poichè non sono riuscito a avviare Debian in nessun modo, né in recovery mode ne senza interfaccia grafica, ho rinstallato tutto da zero.

Ho installato i driver sbagliati?
Come posso riuscire a collegarmi al monitor esterno?

Se può essere utile:

$ lspci -k | grep -EA3 'VGA|Display'
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
        Subsystem: Hewlett-Packard Company UHD Graphics 630 (Mobile)
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] (rev a1)
        Subsystem: Hewlett-Packard Company GP107GLM [Quadro P600 Mobile]
        Kernel modules: nouveau
3c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)

Grazie,
Rox3.

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1448

Rox3 ha scritto:

La cassa era impostata in "pairing-mode", la connetto senza problemi sia a Windows (sulla stessa macchina) sia ad un Mac. Ho fatto delle prove anche con un cellulare e ottengo lo stesso risultato.


Cerca di ottenere un log relativo al riconoscimento delle casse: qui le indicazioni su come ottenere log da buedevil bluedevil
Rox3 ha scritto:

ho provato a collegare il mio computer ad un monitor esterno, tramite cavo hdmi-hdmi, ma il risultato è che Debian non lo vede


Che desktop environment utilizzi ? Prova a verificare l'output del comando xrandr.
Rox3 ha scritto:

Non mi è ben chiara la relazione tra 'nouveau.modeset=0' (parametro di boot


Disattiva il modesetting per il modulo del kernel nouveau per la scheda grafica nvidia (che non va bene evidentemente per la tua scheda grafica nvida)
Rox3 ha scritto:

Finita l'istallazione ho riavviato il pc e dopo il menu di grub Debian non riusciva più a partire.


Le installazioni con sezione grafica ibrida sono spesso più difficili da mettere a punto. In ogni caso, devi installare i moduli proprietari del kernel per la scheda grafica nvidia, ma deve rimanere come scheda grafica principale quella intel: un software "terzo" gestirà il passaggio dall'una all'altra. Considera, comunque, che l'output video finale è sempre gestito dalla scheda grafica intel. Suggerirei di usare il sistema inizialmente con quella intel, impratichirti un po' con Debian e poi provare ad installare il supporto per entrambe le schede grafiche.

Ritratto di Rox3
Rox3
(Junior)
Offline
Junior
Iscritto: 01/01/2020
Messaggi: 10

Per quanto riguarda il monitor esterno dopo un po' di ricerca ho capito che, dalle impostazioni del BIOS, dovevo disattivare la modalità 'ibrida' per la gestione delle schede video.
Questo mi ha permesso di avviare Debian senza 'nouveau.modeset=0' come parametro del kernel e di collegarmi ad un monitor esterno senza problemi. In questa modalità non riesco più a controllare la luminosità del monitor integrato del computer (indipendentemente dal fatto che sia collegato o meno al monitor esterno), luminosità che rimane fissa al massimo (molto fastidiosa).

Ho fatto delle prove su una live persistence di Debian dove, dopo aver installato i driver nvidia (https://wiki.debian.org/NvidiaGraphicsDrivers), al boot necessito del parametro 'nouveau.modeset=0' e una volta avviato riesco a controllare il livelo di luminosità, ma la grafica del desktop appare più grande come se il sistema non gestisse corretamente il numero di pixel.

Qualche consiglio per l'utilizzo con driver sia nouveau sia nvidia?

Graze,
Rox3.

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1448

Rox3 ha scritto:

Ho fatto delle prove su una live persistence di Debian dove, dopo aver installato i driver nvidia (https://wiki.debian.org/NvidiaGraphicsDrivers), al boot necessito del parametro 'nouveau.modeset=0' e una volta avviato riesco a controllare il livelo di luminosità, ma la grafica del desktop appare più grande come se il sistema non gestisse corretamente correttamente il numero di pixel.


Prova a fornire i log di sistema dopo il boot dalla live per verificare effettivamente cosa accade. Inoltre, la luminosità non si modifica neppure con i tasti previsti a tal scopo della tastiera ?

Inoltre, hai risolto con le casse esterne bluetooth ?

Ritratto di Rox3
Rox3
(Junior)
Offline
Junior
Iscritto: 01/01/2020
Messaggi: 10

La luminosità non si modifica neppure con i tasti previsti a tal scopo della tastiera, ma riesco a controllarla solo con

xrandar --output eDP-1 --brightness 0.7

Suppongo che il probelma stia nel fatto che avendo impostso la grafica su 'discreta' dal bios il sistema non vede più la scheda video intel:
$ lspci -k | grep -EA3 'VGA|Display'
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] (rev a1)
	Subsystem: Hewlett-Packard Company GP107GLM [Quadro P600 Mobile]
	Kernel driver in use: nouveau
	Kernel modules: nouveau

E quindi non riesce a gestire la luminosità.
Mentre in precedenza con l'opzione ibrida nel bios il sistema vedeva sia la scheda interna intel che la scheda dedicata nvidea.

homeless ha scritto:


Inoltre, hai risolto con le casse esterne bluetooth ?


Non ho ancora fato passi avanti, sto cercando di risolvere un problema alla volta, e quello riguardante il video ha la precedenza.

Come richiesto allego il file del log di sistema dopo il boot sia per la versione debian intallata (driver noveau) sia per la versione debian live (driver nvidia).

Allego inoltre due screenshot uno relativo a noveau l'alto a nvidia che mostrano come i driver nvidia gestiscano in maniera non corretta la risoluzione in pixel.

dmseg.txt log di sistema con driver noveau
dmesg_live.txt log di sistema con driver nvidia
screenshot_noveau.png grafica con driver noveau
screenshot_nvidia.png grafica con driver nvidia

Attached images:

AllegatoDimensione
dmseg.txt 60.98 KB
dmesg_live.txt 59.82 KB