problema aggiornamento libc6 dopo upgrade a buster

6 risposte [Ultimo contenuto]
Ritratto di rube
rube
(Newbie)
Offline
Newbie
Iscritto: 06/09/2019
Messaggi: 5

Ciao a tutti.
Spiego il problema perchè magari qualcuno di voi conosce una soluzione.
Ho una VPS (inizializzata con debian 8) sulla quale ho effettuato upgrade a 9 e in seguito a Buster. Tutto bene durante l'upgrade.
Tuttavia appena provo nuovamente ad aggiornare (apt-get upgrade) il sistema mi dice

Kernel must be upgraded

This version of the GNU libc requires kernel version 3.2 or later.
Please upgrade your kernel before installing glibc.

Il problema è che non posso aggiornare il kernel perchè il fornitore della VPS non lo consente, e quindi non posso più aggiornare nulla.
ho provato a fare un apt-mark hold libc6 ma non mi fa comunque procedere.
C'è qualcosa che posso fare per mantenere il sistema aggiornato (downgrade a stretch è escluso perchè troppo pericoloso).

Grazie!

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1382

Che versione di kernel stai utilizzando?

Ritratto di rube
rube
(Newbie)
Offline
Newbie
Iscritto: 06/09/2019
Messaggi: 5

uname -r
2.6.32-042stab139.1

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1382

È un kernel molto vecchio, non più supportato. Sei al di fuori dei requisiti di Debian Buster, al quale non hai sicuramente effettuato un aggiornamento completo, stante la situazione. Mi chiedo come il gestore del vps possa garantirne la sicurezza, fatto salvo non apporti lui stesso tutti i possibili aggiornamenti di sicurezza.

Ritratto di rube
rube
(Newbie)
Offline
Newbie
Iscritto: 06/09/2019
Messaggi: 5

Esatto. Infatti la situazione è abbastanza assurda. Mi hanno risposto che sulle vps non è possibile aggiornare il kernel è di passare ad un server dedicato (che costa 5 volte tanto). Peccato che ormai è in produzione quindi per un po' resterà così. Poi migrerò verso altro provider.

Ritratto di rube
rube
(Newbie)
Offline
Newbie
Iscritto: 06/09/2019
Messaggi: 5

Esatto. Infatti la situazione è abbastanza assurda. Mi hanno risposto che sulle vps non è possibile aggiornare il kernel è di passare ad un server dedicato (che costa 5 volte tanto). Peccato che ormai è in produzione quindi per un po' resterà così. Poi migrerò verso altro provider.

Ritratto di rube
rube
(Newbie)
Offline
Newbie
Iscritto: 06/09/2019
Messaggi: 5

Esatto. Infatti la situazione è abbastanza assurda. Mi hanno risposto che sulle vps non è possibile aggiornare il kernel è di passare ad un server dedicato (che costa 5 volte tanto). Peccato che ormai è in produzione quindi per un po' resterà così. Poi migrerò verso altro provider.