installazione da usb minimale e pacchetti da rete

10 risposte [Ultimo contenuto]
Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Buonasera a tutti. Sono nuovo di debian, ma non di linux , diciamo che sono circa 20 anni che utilizzo
la mitica slackware !!! Wink
Mi è venuta voglia di cambiare, di provare questa distribuzione che ai fatti è vecchia quasi come la slackware
e a detta di molti anche ben seguita e aggiornata.

Il mio scenario è questo , mi creo la usb minimale copiando su una pennetta il file netinst ISO-64bit PC

Dopodichè Faccio partire da BIOS la usb e parte il programma di installazione. Il problema è che mi chiede i pacchetti da

CDRom. Io mi aspettavo ci fosse una voce che mi guidasse nella configuarazione rete e scaricasse i pacchetti scelti.

Cosa sto sbagliando?

Ditemi voi

Grazie
Saluti

Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Mi domando se il mio è problema serio o se anche sto forum è morto ...

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1300

Ciao e benvenuto nel forum.

Se il problema sia serio oppure no, dipende dalle tue esigenze e aspettive: presumo di no, dal momento che pochi giorni fa ho installato senza nessuna difficoltà proprio da una immagine ISO netinst di Debian Stable ("Stretch") 9.6.

Alcune domande.

Puoi indicare esattamente il nome dell’immagine ISO che hai prelevato dai repository Debian (puoi fornire anche il link) ?

Come l’hai trasferita (con quali comandi) sul dispositivo USB ?

Hai verificato l’integrità dell’immagine ISO dopo che è stata trasferita sul pen drive USB ?

Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Buonasera, grazie della risposta

il file ce ho prelevato è questo

https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.6.0-amd64-netinst.iso

l'ho trasferito nell' usb con dd if=/percorso/debian-9.6.0-amd64-netinst.iso of=/dev/sdd/ BS=4M

il file non è corrotto.

Il problema che noto è che il menu di installazione che tra l'altro è anche grafico, mi fa scegliere la lingua
e tastiera ma non mi chiede nulla sulla rete e poi mi chiede sempre i dati dal CD rom
non c'è affatto un menu che chiede i pacchetti .
Solo una volta il menu aveva delle voci in più e mi ha chiesto di prelevare i pacchetti , ma mi chiedeva
nome utente e password del sito , le connessioni disponibili erano ftp e http, http
ma poi falliva sempre la connessione.
La mia linea internet è sempre accesa e funzionante.

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1300

AndyReed ha scritto:

il menu di installazione che tra l'altro è anche grafico, mi fa scegliere la lingua
e tastiera ma non mi chiede nulla sulla rete e poi mi chiede sempre i dati dal CD rom
non c'è affatto un menu che chiede i pacchetti. Solo una volta il menu aveva delle voci in più e mi ha chiesto di prelevare i pacchetti , ma mi chiedeva nome utente e password del sito , le connessioni disponibili erano ftp e http, http ma poi falliva sempre la connessione.


Se l'installer che hai usato è stato sempre lo stesso non c'è motivo per avere un comportamento erratico come quello che hai descritto. Quale dispositivo di rete stai usando per collegare il computer da installare ?

In ogni caso, l'installatore non ha un "menù che chiede i pacchetti", ma un menù che permette di scegliere il repository da configurare per prelevare i pacchetti (vedi qui per i passi previsti).

Qui trovi un video di esempio di installazione di Debian da netinst: https://www.youtube.com/watch?v=nFfheO2Ikok
:a te cosa accade ed in che modo differisce dal video ?

Infine,se utilizzi l'installer testuale e non quello grafico, se premi ALT-F4 ti si apre una finestra di terminale dove sono visualizzati i log dell'installer e che, se vuoi, puoi utilizzare per attivare una finestra di terminale per impartire comandi per trasferire, ad esempio, su un pendrive il file /var/log/syslog che contiene tutti i log dell'installer al fine di analizzare cosa accade in differita nel tuo caso specifico. Sarebbe interessante verificare, in particolare, se è riconosciuta la scheda di rete.

In alternativa, realizza una registrazione video con il cellulare e condividilo, ad esempio, con tinyupload.com o con youtube.com

Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Ciao di seguito una serie di foto per farti vedere le varie schermate .










Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1300

Dalle immagini che hai inviato, sospetto che il disco di installazione di Debian sia "corrotto", poiché non riesce a completare il download (dal supporto USB) dei pacchetti essenziali alle successive fasi di installazione. Questo, in senso lato, può conseguire ad una immagine ISO scaricata in modo incompleto o danneggiata oppure ad una errata procedura di trasferimento al supporto USB oppure ad un difetto del supporto USB (per cui il dato trasferito è "corrotto"). Puoi usare il link del video che ti ho inviato per confronto per vedere le differenze rispetto ad una installazione regolare. Puoi sempre inviare i log dell'installer.

edit: a latere segnalo che stai usando una scheda madre che sembrerebbe abbastanza datata (il manuale, dal sito del produttore, è datato 2005, ma questo non dovrebbe avere a che fare con l'installer). Sicuro che tutti i componenti hardware siano regolarmente funzionanti ?

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1300

@AndyReed: hai provato a ricreare il supporto di installazione ed installare ?

Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Guarda la usb l'ho ogni volta partizionata e formattata e copiato la ISO con dd, sinceramente mi
stavo addentrando in debian perchè cercavo un qualcosa più automatizzato visto che qualsiasi
produttore mette pacchetti per debian .deb
Ma tutti sti problemi con slackware non li ho mai avuti
e poi anche il forum italia è praticamente morto, tranne te nessuno che risponde...

non mi fraintendere, non conosco debian però io con la slackware ci sono cresciuto.

Grazie per la tua assistenza , quando avrò un pò di tempo riproverò a fare tutto e ti aggiornerò sulla
situazione.

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1300

Provenendo da slackware dovresti berti l’installazione di Debian in un sol sorso.

Ritratto di AndyReed
AndyReed
(Junior)
Offline
Junior
Iscritto: 03/01/2019
Messaggi: 6

Ma infatti non mi spaventa l'installazione, il mio problema è che il CD non mi funziona e devo necessariamente utilizzare l'installazione USB...