Pc bloccato al login: problema con driver nvidia

7 risposte [Ultimo contenuto]
Ritratto di marcoap65
marcoap65
(Geek)
Offline
Geek
Iscritto: 27/08/2015
Messaggi: 103

Salve a tutti, oggi ho fatto un "apt-get dist-upgrade" e da quel momento il pc non entra più nel login fermandosi ai messaggi iniziali e apt-get entrando in modalità ripristino non funziona dando il seguente errore:

Rimozione di xserver-xorg-video-nvidia <(384.111-3~bpo9+1) 
dpkg: errore nell'elaborare il pacchetto xserver-xorg-video-nvidia (--remove): il sottoprocesso installato script posr-removal ha restituito lo stato di errore 128.
Si sono verificati errori nell'elaborazione : xserver-xorg-video-nvidia
E: Sub-process /usr/bin/dpkg returned an error code

Purtroppo quando mesi fa ho installato i driver nvidia devo aver commesso qualche errore. Il pc ha sempre funzionato anche se a volte lo spegnimento era lento e la sospensione mi ridava una schermata nera. Ora penso che il difetto abbia bloccato qualche processo. la mia domanda è: posso eliminare del tutto questi driver per tornare al driver nouveau?
Non so quali altre informazioni servano.
Grazie

Ritratto di marcoap65
marcoap65
(Geek)
Offline
Geek
Iscritto: 27/08/2015
Messaggi: 103

Sono riuscito a rientrare editando il file /etc/X11/xorg.conf . Ho sostituito nella Sezione "Device" la voce da driver da "nvidia" a "vesa". Al riavvio la risoluzione era bassissima ( le immagini erano enormi). Allora ho rimosso xserver-xorg e lo ho reinstallato. Adesso la risoluzione è migliorata ma non ancora come prima. Ho notato che è scomparso il file /etc/X11/xorg.cong.
Come posso fare a ritornare alla situazione precedente l'installazione dei driver nvidia? Ho letto vari consigli su come configurare xorg ma sinceramente non so ancora come fare. Dalle impostazione del Sistema Operativo il monitor non è riconosciuto.
Posso mandare qualche dato per aiutare a comprendere dove sia il problema?
Grazie

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 26/02/2018
Messaggi: 55

prova a dare un'occhiata qui:

https://wiki.debian.org/it/NvidiaGraphicsDrivers#Ripristino_in_caso_di_fallimento

Ritratto di marcoap65
marcoap65
(Geek)
Offline
Geek
Iscritto: 27/08/2015
Messaggi: 103

Ciao, grazie mille per la risposta. Avevo provato questi comandi dopo aver parzialmente risolto ieri ma la risoluzione rimaneva comunque bassa. Poi per la disperazione, dopo vari altri tentativi, ho reinstallato i driver nvidia dando semplicemente sudo apt-get install nvidia-driver. A questo punto la situazione è tornata come prima del blocco dovuto al dist-upgrade, cioè tutto ok ma tempo di attesa allo spegnimento ( con countdown e messaggio "a stop job is running for...Manager for UID 116" alternato a "...User Debian-gdm") e sfondo multicolore dopo sospensione.
Ieri nel mettere mano ai file di configurazione mi sono ricordato che quando installai la prima volta i driver nvidia lo feci "manualmente" scaricando il pacchetto dal sito, ma nei vari passaggi:
1- installare dei pacchetti necessari,
2- editare il file /etc/modprobe.d/blacklist-nouveau.conf ( che ora si chiama nvidia-blacklists-nouveau.conf!) con contenuto

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

3- fermare il server X da console ( sudo service gdm stop )
4- installare il pacchetto

Ho saltato il terzo passaggio
Ora il problema anche dal messaggio finale sembra proprio che sia un processo aperto che va in conflitto con i driver nvidia ( è nouveau? è gdm ? ).
Cosa posso vedere per capire l'origine del problema?
Grazie per il tempo dedicato.

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 26/02/2018
Messaggi: 55

se hai dubbi che nouveau sia caricato prova con

# lsmod | grep nouveau

per vedere chi è l'utente 116

$ cat /etc/passwd| grep 116

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1092

Sì, ok tutto, ma qual è la tua scheda video?

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di marcoap65
marcoap65
(Geek)
Offline
Geek
Iscritto: 27/08/2015
Messaggi: 103

La scheda video è una nvidia quadro k 620.
Al comando lsmpod non ho risposta dal terminale.
Al comando cat la risposta è:

root@asus:/home/icaro# cat /etc/passwd| grep 116
pulse:x:111:116:PulseAudio daemon,,,:/var/run/pulse:/bin/false
Debian-gdm:x:116:122:Gnome Display Manager:/var/lib/gdm3:/bin/false
root@asus:/home/icaro# 

quindi l'UID 116 è Debian-gdm... come faccio a fermare questo processo (si chiama così?), o meglio a non farlo attivare, in modo da non avere conflitto e tempo di attesa ad ogni spegnimento? ( fino a prima di ieri l'attesa era una volta ogni 4/5 spegnimenti, ora ad ogni spegnimento)

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 26/02/2018
Messaggi: 55

è il display manager di gnome (quello che ti chiede utente /password) che in fase di chiusura attende il termine di qualche processo.
Non sono ferratissimo con gnome e possiamo attendere che qualcun altro venga in aiuto.

Io proverei ad installare un altro display manager(lightdm ad esempio) per vedere l'effetto che fa Wink