Problemi prima installazione Debian Stretch

2 risposte [Ultimo contenuto]
Ritratto di Mbegatr
Mbegatr
(Newbie)
Offline
Newbie
Iscritto: 12/11/2017
Messaggi: 1

Ciao a tutti ragazzi, spero di aver azzeccato la giusta sezione Big Grin

Sono appena reduce dalla prima installazione di Debian Stretch (KDE) sul mio HP 250 G4, immancabili i primi problemi al primo avvio pero' Laughing

Allora, anzitutto ci tengo a premettere che, stranamante, i tempi di avvio sono biblici, non vorrei pero' ciò possa essere collegato al problema che sto per descrivervi.

All'avvio riscontro questi messaggi:

bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.b
Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_fw.bin
Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_fw.bin
rtl8723be 0000:02:00.0: firmware: failed to load rtlwifi/rtl8723b
efw.bin

Riguardante l'ultima stringa infatti il Wi-Fi non funziona, purtroppo la mia scheda di rete necessita di una piccola configurazione iniziale prima di funzionare, già capitato anche con altre distro.
Mi basta semplicemente (solitamente, in questo caso no) dare questi 3 comandi in fila

sudo modprobe rtl8723be
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

E tutto funziona, ma non in questo caso.. ho anche provato a mettere ant_sel=1 ma niente, il Wi-Fi non va, non mi trova connessioni nonostante pero' la scheda di rete venga correttamente riconosciuta anche in fase di installazione.

La cosa assurda che pero' mi è capitata, è che non appena davo l'ultimo comando, quello con cui selezionavo l'antenna per intenderci, il pc si freeza e non risponde più ad alcun comando, 2 volte ho dovuto spegnere dal tasto fisico, la terza volta ho aspettato e si sbloccava dopo una 20ina di secondi.

Perdonate la prolissità ma ci tenevo ad essere il più chiaro possibile per esprimervi per bene il problema, spero fortemente qualcuno di voi riesca a darmi una mano! sto impazzendo! At Wits End

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Credo basti installare il firmware (pacchetto firmware-realtek, download).

Ritratto di Simo84
Simo84
(Junior)
Offline
Junior
Iscritto: 03/12/2017
Messaggi: 9

Ciao, modifica il file sources.list aggiungendo CONTRIB NON-FREE in fondo ad ogni riga, salva ed esci e poi dai apt-get update, fatto questo da synaptic cerca firmware-linux, firmware-linux-free e firmware-linux-nonfree, installa questi 3 pacchetti riavvia e dovresti aver risolto tutti i problemi.