Debian 9.1 dopo aggiornamento nautilus sparito

3 risposte [Ultimo contenuto]
Ritratto di abe001
abe001
(Junior)
Offline
Junior
Iscritto: 30/07/2017
Messaggi: 17

Ciao sono passato dalla versione 8 di Debian alla 9 e poi alla 9.1.
Durante il passaggio dalla 8 alla 9 ho avuto dei problemi infatti ho poi dovuto eseguire apt in live con il seguentecomando:apt --fix-broken install.
Tutto sembrava risolto ho poi scoperto invece che nautilus non funziona, non me lo da come installato e se provo ad installarlo mi dice:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 nautilus : Dipende: libnautilus-extension1a (= 3.22.3-1) ma non sta per essere installato
            Dipende: nautilus-data (= 3.22.3-1) ma la versione 1:3.4.1-0ubuntu1 sta per essere installata
            Raccomanda: gnome-sushi ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Cosa posso fare per tornare a gestire i file in grafica?

Qui c'è il mio source.list:

deb http://httpredir.debian.org/debian stretch main
deb http://httpredir.debian.org/debian stretch-updates main
deb http://security.debian.org stretch/updates main
#deb https://apt.dockerproject.org/repo/

L'unica alternativa alla memoria sono le periferiche di input output https://abe001.wordpress.com/

Ritratto di thece
thece
(Geek)
Offline
Geek
Iscritto: 12/05/2015
Messaggi: 71

Wave

hai un bel problema di dipendenze.
La mia personale esperienza dice: meglio reinstallare da zero che aggiornare di versione in versione.

Se proprio hai voglia di metterti a ripulire / risolvere le dipendenze, io come prima cosa completerei il file /etc/apt/sources.list in questo modo

deb http://ftp.debian.org/debian/ stretch main contrib non-free
# deb-src http://ftp.debian.org/debian/ stretch main contrib non-free
 
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
# deb-src http://ftp.debian.org/debian/ stretch-updates main contrib non-free
 
deb http://security.debian.org/ stretch/updates main contrib non-free
# deb-src http://security.debian.org/ stretch/updates main contrib non-free

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 1939

abe001 ha scritto:

...ma la versione 1:3.4.1-0ubuntu1 sta per essere installata

Un pacchetto di Ubuntu ??????
Sicuro di non avere qualche repository "strano" in /etc/apt/sources.list.d ?
Una volta sistemati i repository prova la solita sequenza :

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Ritratto di abe001
abe001
(Junior)
Offline
Junior
Iscritto: 30/07/2017
Messaggi: 17

Ho fatto ciò che mi avete detto ed il pc ha frullato un bel po ma nautilus niente, mi dava due errori sulle dipendenze da installare, così ho scaricato il punto deb delle due librerie, ho dato di dpkg, installato nautilus e adesso va che è una meraviglia. Grazie!

L'unica alternativa alla memoria sono le periferiche di input output https://abe001.wordpress.com/