Problema estensioni disabilitate e non attive in chromium 55 su debian stretch 9

11 risposte [Ultimo contenuto]
Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

ciao ragazzi sto verificando una problematica un po fastidiosa su chromium 55 installato su debian stetch,tenendo conto che le mie ricerce sul web non hanno portato esiti positivi alla risoluzione del problema. Vi posto delle foto per comprendere meglio la situazione,in sintesi la voce estensioni risulta disattivata in chromium e qulasiasi estensione si cerca di installare restituisce come errore la voce di non attiva,quello che non riesco a comprendere (nonostante abbia messo la spunta su sviluppatore e barrato la voce attiva) a cosa sia dovuta questa anomalia.

[img][/img]

[img][/img]

[img][/img]

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Non sei l'unico. E' un problema che riscontro anch'io su Debian testing dopo l'aggiornamento di lunedì scorso.

Ho provato a contattare l'assistenza Google, ma anche loro non hanno idea di cosa vada storto...

Comunque penso sia un bug di Debian. Questa mattina ho provato ad installare la versione 56 presente nel repo Sid e il problema persiste.
La cosa strana è che io ho installato anche Chrome 56 e lui funziona regolarmente...

Oggi apro una segnalazione bug su Debian e temporaneamente cerco un browser alternativo.

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

theShort ha scritto:

Non sei l'unico. E' un problema che riscontro anch'io su Debian testing dopo l'aggiornamento di lunedì scorso.

Ho provato a contattare l'assistenza Google, ma anche loro non hanno idea di cosa vada storto...

Comunque penso sia un bug di Debian. Questa mattina ho provato ad installare la versione 56 presente nel repo Sid e il problema persiste.
La cosa strana è che io ho installato anche Chrome 56 e lui funziona regolarmente...

Oggi apro una segnalazione bug su Debian e temporaneamente cerco un browser alternativo.

ciao e grazie per la tempestiva risposta Smile la problematica su firefox non si presenta........il problema è circoscritto a chromium ( non ho verificato se su chrome invece la funzionalità è regolare)

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Intanto ho mandato una segnalazione bug su Debian, questo è il link:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854582

Vediamo che succede.

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

ottimo,anche se credo più che un problema di debian sia un problema di chromium e quindi di google....

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Ciao, non so se hai visto già che su bugs.debian mi hanno risposto.

Sostanzialmente in Chromium, al momento, non è possibile aggiungere o usare estensioni perché è stata disabilitata di default l'opzione per farlo. Non ho capito per quale motivo si sia arrivati a questo, ma dovrebbe essere una cosa temporanea.

Ad ogni modo, basta avviare il terminale e aprire il file:

/etc/chromium.d/default-flags

e alla fine del file aggiungere la stringa:

export CHROMIUM_FLAGS='--enable-remote-extensions'

In questo modo tutto dovrebbe tornare alla normalità.

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

grazie per le info,adesso provo da terminale con questi comandi che mi hai scritto e poi faccio sapere come è andata

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

theShort ha scritto:

Ciao, non so se hai visto già che su bugs.debian mi hanno risposto.

Sostanzialmente in Chromium, al momento, non è possibile aggiungere o usare estensioni perché è stata disabilitata di default l'opzione per farlo. Non ho capito per quale motivo si sia arrivati a questo, ma dovrebbe essere una cosa temporanea.

Ad ogni modo, basta avviare il terminale e aprire il file:

/etc/chromium.d/default-flags

e alla fine del file aggiungere la stringa:

export CHROMIUM_FLAGS='--enable-remote-extensions'

In questo modo tutto dovrebbe tornare alla normalità.

root@gennarogiugliano-iMac-2:/home/gennarogiugliano# /etc/chromium.d/default-flags
bash: /etc/chromium.d/default-flags: Permesso negato
root@gennarogiugliano-iMac-2:/home/gennarogiugliano# 

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Devi aprire il file con un editor di testo

su -
password
gedit /etc/chromium.d/default-flags

Se non usi gedit, al suo posto metti l'editor che preferisci.

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

theShort ha scritto:

Devi aprire il file con un editor di testo

su -
password
gedit /etc/chromium.d/default-flags

Se non usi gedit, al suo posto metti l'editor che preferisci.

ciao the short,grazie per il tuo prezioso aiuto,seguendo il tuo suggerimento sono riuscito a risolvere la probematica legata alle estensioni disattivate in chromium 55 su debian........posto una foto alla comunità per il riscontro positivo e nel rinnovarti i ringraziamenti vado anche a condividere la info sulla pagina facebook del gruppo debian italia dove avevo messo anche su quello spazio un post per ricevere aiuto alla risoluzione del problema. Con questo possiamo mettere all'inizo del post risolto ( in modo brillante) un nuovo quesito per questo fantastico system,ciao Smile

gennaro

[img][/img]

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Per farla breve: quando i plugin sono abilitati, Chromium scarica dal Web un componente aggiuntivo che accede al microfono e, se l'utente dice "OK Google" fa partire il riconoscimento vocale. Visto che questo componente è un binario senza sorgente, è contrario alla filosofia stessa di Debian. Poiché non c'è un modo per lasciare i plugin abilitati e impedire a Chromium di scaricare il componente binario, la scelta è caduta sul disabilitare i plugin.

Il tutto è riassunto in cinque righe nel file NEWS in /usr/share/doc/chromium.

Hai tre vie: abilitare tutti i plugin usando --enable-remote-extensions, selettivamente abilitare solo quelli che voi con --load-extension=, o rinunciare ai plugin.

Ovviamente hai sempre la quarta via: abbandonare definitivamente Chromium e usare FireFox, ad esempio.