LAMP- PHP non và

5 risposte [Ultimo contenuto]
Ritratto di edotux
edotux
(Junior)
Offline
Junior
Iscritto: 20/06/2015
Messaggi: 32

Un saluto a tutto il forum.
Ho installato un LAMP in Debian 8 Jessie per poi installare Joomla! seguendo la guida debian, ma quando verificocon info.php non mi appare la schermata della guida ma un messaggio di errore
" 404
Not Found

The requested URL /info.php was not found on this server.
Apache/2.4.10 (Debian) Server at localhost Port 80".

Grazie in anticipo a tutti coloro che vorranno aiutarmi.

p.s.

Ho dato una occhiata ai post sullo stesso problema ma non ho risolto.

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 423

Ciao e benvenuto.
Il file info.php dove l'hai messo?
Per vederlo dovresti averlo messo nella direttamente all'interno della DocumentRoot che trovi nel file di configurazione di Apache /etc/apache2/sites-enabled/000-default
Se hai seguito la guida Debian, e se ho capito bene, li` ti dice di metterlo nella tua home...

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di edotux
edotux
(Junior)
Offline
Junior
Iscritto: 20/06/2015
Messaggi: 32

Grazie Franz per il tuo contributo, ho risolto (un paio di giorni fa e purtroppo mi è mancato il tempo per postare) così:

dopo aver letto un po sul funzionamento di Apache e confrontato le due guide

https://wiki.debian.org/it/LaMp

http://guide.debianizzati.org/index.php/Installare_un_ambiente_LAMP:_Linux,_Apache2,_SSL,_MySQL,_PHP5

nonché la descrizione realtiva alla libreria libapache2-mod-php5 ho capito che mancava proprio la apache2-mpm-prefork.
Una volta installata quest'ultima ha funzionato tutto anche Joomla! 3.4.. che ho installato così:

1. Downlaod Joomla!
2. mkdir -m 0755 /var/www/html/joomla
3. decompressione file nella cartella creata al punto 2
4. chown -R www-data:www-data /var/www/html/joomla
5. Installazione Joomla! da browser -> localhost/joomla
6. Seguire istruzioni
7. Lanciare Joomla! da browser localhost/joomla/administrator
8. fine

ed è andato tutto a buon fine.

Sperando di essere stato utile al forum un saluto a tutto il forum.

p.s.
ho messo il file info.php in /var/www/html

Ritratto di Claudio_fe11
Claudio_fe11
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/02/2011
Messaggi: 454

Hi edotux,

hai controllato i permessi della cartella "html"?

Ciao, Claudio

"Scriva le equazioni sulla lavagna". Poi aggiunse,
"Per favore vada piano, non afferro le cose molto in fretta".

Albert Einstein

Ritratto di edotux
edotux
(Junior)
Offline
Junior
Iscritto: 20/06/2015
Messaggi: 32

Si ho controllato, cmq grazie per il tuo suggerimento.
Ciao
Fabrizio

p.s.
avevo dimenticato di cambiare l'etichetta in risolto.

Ritratto di Claudio_fe11
Claudio_fe11
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/02/2011
Messaggi: 454

Di niente, ciao. Wave

Claudio

"Scriva le equazioni sulla lavagna". Poi aggiunse,
"Per favore vada piano, non afferro le cose molto in fretta".

Albert Einstein