bluetooth non visto

9 risposte [Ultimo contenuto]
Ritratto di fgregori
fgregori
(Junior)
Offline
Junior
Iscritto: 20/04/2014
Messaggi: 9

Ciao a tutti, ho cerato un po' di rete e nel forum ma non ho trovato topic che potessero essermi utili e perciò chiedo nuovamente aiuto alla comunity.
Mi trovo ad affrontare un problema con il bluetooth che sembra esistere ma non viene individuato. Il "paradosso" è che quando da terminale digito:

/etc/init.d/bluetooth start

ottengo il seguente risultato:
[ ok ] Starting bluetooth: bluetoothd rfcomm

quando poi però provo a cercare il dispositivo non riesco a vederlo:
~$ hcitool dev

Devices:

Quindi, da quello che capisco non viene visto nessun bluetooth.

Qualcuno ha qualche idea di quale possa essere la procedura per risolvere il problema?

Grazie

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

È possibile che la scheda bluetooth sia la scheda Wireless (nel mio caso wlan0 è sia wireless che Bluetooth) prova a disattivare la rete e riprova.
Ciao! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di fgregori
fgregori
(Junior)
Offline
Junior
Iscritto: 20/04/2014
Messaggi: 9

Fatto e rifatto, il risultato non cambia.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Marca e modello dell'hardware? Output di "lspci -v"? Output di dmesg?

Ritratto di fgregori
fgregori
(Junior)
Offline
Junior
Iscritto: 20/04/2014
Messaggi: 9

Ciao,
l'output di "lspci -v" riferito al bluetooth è il seguente:

0a:00.1 Bluetooth: Ralink corp. Device 3298
Subsystem: Hewlett-Packard Company Device 18ec
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at 74500000 (32-bit, non-prefetchable) [=64K]
Capabilities:

quello dmesg è:

[ 23.698530] Bluetooth: Core ver 2.17
[ 23.698552] NET: Registered protocol family 31
[ 23.698554] Bluetooth: HCI device and connection manager initialized
[ 23.698562] Bluetooth: HCI socket layer initialized
[ 23.698573] Bluetooth: L2CAP socket layer initialized
[ 23.698578] Bluetooth: SCO socket layer initialized
[ 23.804161] Bluetooth: RFCOMM TTY layer initialized
[ 23.804174] Bluetooth: RFCOMM socket layer initialized
[ 23.804182] Bluetooth: RFCOMM ver 1.11
[ 23.962822] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 23.962826] Bluetooth: BNEP filters: protocol multicast
[ 23.962857] Bluetooth: BNEP socket layer initialized

le caratteristiche tecniche del notebook sono le seguenti:

http://h10025.www1.hp.com/ewfrf/wc/document?cc=it&lc=it&dlc=it&docname=c03655936

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Se non hai installato il pacchetto firmware-ralink, fallo.
Se questo non risolve, posta il resto di dmesg, perché la porzione che hai riportato è solo quella relativa all'infrastruttura BT che viene correttamente inizializzata. Dovrebbe esserci qualcosa sul dispositivo.
Anche l'output di lsmod potrebbe essere utile.

Ritratto di fgregori
fgregori
(Junior)
Offline
Junior
Iscritto: 20/04/2014
Messaggi: 9

Il pacchetto firmware-ralink era già installato.
Allego i file contenenti gli output dei comandi dmesg e lsmod.

Non voglio neanche immaginare quanti errori troverai quando vedrai i contenuti...

AllegatoDimensione
dmesg.txt 58.13 KB
lsmod.txt 5.3 KB
Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Il tuo dispositivo è un combo con un chip wifi (RT3290) e uno bluetooth (RT3298). Purtroppo il driver Linux ufficiale che usi attualmente (rt2800pci) riesce a pilotare la parte wifi ma non quella bluetooth.

Sembra che esista una soluzione per Ubuntu, con tanto di spiegazione passo-passo e un aggiornamento per i kernel più recenti.

Purtroppo non è detto né che funzioni con Debian, né che risolva del tutto il problema. Non ti resta che provare! Wink

Ritratto di fgregori
fgregori
(Junior)
Offline
Junior
Iscritto: 20/04/2014
Messaggi: 9

Ciao, ho provato a seguire la spiegazione ma la compilazione non è andata a buon fine.
C'è stato un errore, allego il file di log con quanto è successo.

Ho guardato l'aggiornamento che mi hai indicato e ho desistito, non vorrei fare cavolate. A questo punto userò semplicemente il caro e vecchio cavetto usb per la connessione al dispositivo esterno e quindi risolvo il problema in questo modo, dal mio punto di vista è la soluzione più semplice e rapida.
Grazie comunque per i suggerimenti.
Ciao
Filippo

AllegatoDimensione
make.txt 2.32 KB
Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Probabilmente il modulo è per una versione diversa del kernel. Pazienza! Sad