epiphany e flahplayer

8 risposte [Ultimo contenuto]
Ritratto di scuola
scuola
(Newbie)
Offline
Newbie
Iscritto: 26/04/2014
Messaggi: 5

Salve,
sono un nuovo utente.
Ho installato debian wheezy 7.04.
Ho installato opera e ho manualmente copiato libflashplayer /versione 10) in /usr/lib/mozilla/plugins.
Con opera e iceweasel posso vedere i filmati youtube e street per view; con epiphany no.
Qualche suggerimento?
Grazie

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

Ciao e benvenuto.
Non so perchè e da dove tu abbia copiato libflashpalyer ( dal sito Adobe ? ) ma in Debian il modo corretto di procedere è il seguente :

1 abilitare i repository contrib e non-free ( quest'ultimo proprio per flash ), vedi qui per i dettagli.

2 a questo punto puoi aggiornare l'elenco dei pacchetti e installare flash con questi comandi :

sudo apt-get update
sudo apt-get install flashplugin-nonfree

e, come puoi leggere sulla pagina dedicata del wiki, anche Epiphany dovrebbe funzionare.
Inoltre se sei proprio nuovo di Debian ti consiglio di leggere o comunque consultare il wiki ufficiale dove puoi trovare una marea di informazioni.
Ultima cosa usa anche la funzione "Search" del forum prima di aprire un nuovo thread perchè molto spesso troverai che il tuo problema è già stato affrontato in precedenza e quindi puoi già trovare la soluzione ad esso.

Ritratto di scuola
scuola
(Newbie)
Offline
Newbie
Iscritto: 26/04/2014
Messaggi: 5

Grazie per tutte le indicazioni.
Mi scuso per evr aperto questo nuovo argomento ma non riuscivo a trovare suggerimenti per risolvere la cosa senza installare l'ultima versione di flashplayer.
Cioè in internet avevo visto che potevo installare flashplayer da debian nel modo normale che hai indicato ma volevo avere la versione 10 di flashplayer perché ho un pc vecchio (pentium 4, 768 mb ram) e pensavo che l'ultima versione di flashplayer fosse lenta.
Ho copiato flashplayer dall'archivio di adobe per linux. In slackware avevo fatto così e ho pensato che andasse bene anche per debian: con Iceweasel e Opera funziona; con Epiphany, no (non capisco perché).
Comunque rimuoverò flashplayer.so da /usr/lib/mozilla/plugins e installerò il pacchetto nonfree da debian.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

scuola ha scritto:

Mi scuso per evr aperto questo nuovo argomento ma non riuscivo a trovare suggerimenti per risolvere la cosa senza installare l'ultima versione di flashplayer.

Tranquillo non devi scusarti di nulla, è solo che se possibile è meglio evitare di aprire thread per problemi già ampiamente trattati.
Diverso il caso, che però non avevi specificato, in cui si vuole o si ha necessità di installare una versione diversa da quella fornita dai repository.

scuola ha scritto:

Cioè in internet avevo visto che potevo installare flashplayer da debian nel modo normale che hai indicato ma volevo avere la versione 10 di flashplayer perché ho un pc vecchio (pentium 4, 768 mb ram) e pensavo che l'ultima versione di flashplayer fosse lenta.

Adobe non sviluppa più flashplayer per linux, l'ultima versione è la 11.2 se non erro, non credo che rispetto alla 10 possa essere tanto più lenta.

scuola ha scritto:

... con Epiphany, no (non capisco perché).

Potrebbe dipendere dal fatto che Epiphany cerca il plugin in una cartella diversa, hai provato a copiarlo anche in $HOME/.mozilla/plugins' ?

Ritratto di scuola
scuola
(Newbie)
Offline
Newbie
Iscritto: 26/04/2014
Messaggi: 5

Citazione:

Potrebbe dipendere dal fatto che Epiphany cerca il plugin in una cartella diversa, hai provato a copiarlo anche in $HOME/.mozilla/plugins' ?

La cartella $HOME/.mozilla/ non ha la cartella plugins.
C'è la cartella $root/.mozilla/plugins. Ci ho copiato libflashplayer ma non funziona in epiphany.

La situazione è questa:

con libflashplayer in /usr/mlib/mozilla/plugins sia in opera che in Iceweasel posso vedere youtube e street per view ma in Epiphany nessuno dei due.

Se tolgo libflashplayer da /usr/mlib/mozilla/plugins posso vedere solo youtube con epiphany, iceweasel e opera ma non street per view (credo che usino gnash).

Installerò flashplugins non free con apt e credo, spero, che funzionerà tutto. Mi interessa che funzioni con epiphany perchè vedo che è più veloce di opera e iceweasel.

Comunque rimane la curiosità di sapere perché copiando libflashplayer in /usr/mlib/mozilla/plugins con opera e iceweasel vedo youtube e street per view e con ephiphany nessuno dei due.....

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1102

Forse perché i due supportano html5 mentre ephifany no.
Nella barra degli indirizzi scrivi per opera opera:plugins e per iceweasel about:plugins e vedi in che posizione trovi il flash player.
Una volta fatto questo prova a visualizzare un video su youtube e a cliccare col tasto destro sul video e vedi cosa esce scritto sulla tendina

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di scuola
scuola
(Newbie)
Offline
Newbie
Iscritto: 26/04/2014
Messaggi: 5

su opera:

Descrizione: Shockwave Flash 10.3 r183
/usr/lib/opera/plugins/libflashplayer.so
(ricordo che l'ho copiato anche qui perché in /usr/lib/mozilla/plugins non funzionava con opera)

e

Shockwave Flash
Descrizione: Shockwave Flash 10.1 r999. Gnash 0.8.11dev, the GNU SWF Player. Copyright (C) 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation, Inc. Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License. For more information about Gnash, see http://www.gnu.org/software/gnash. Compatible Shockwave Flash 10.1 r999.
/usr/lib/mozilla/plugins/flash-mozilla.so

su Iceweasel:

Shockwave Flash

File: libflashplayer.so
Percorso: /usr/lib/mozilla/plugins/libflashplayer.so
Versione:
Stato: attivo
Shockwave Flash 10.3 r183

e

Shockwave Flash

File: libgnashplugin.so
Percorso: /usr/lib/gnash/libgnashplugin.so
Versione:
Stato: attivo
Shockwave Flash 10.1 r999. Gnash 0.8.11dev, the GNU SWF Player. Copyright (C) 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation , Inc. Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License . For more information about Gnash, see http://www.gnu.org/software/gnash . Compatible Shockwave Flash 10.1 r999.

su epiphany:

Shockwave Flash

Shockwave Flash 10.3 r183
Abilitato: Sì
Tipo MIME Descrizione Suffissi
application/x-shockwave-flash shockwave flash swf
application/futuresplash futuresplash player spl

e

Shockwave Flash

Shockwave Flash 10.1 r999.
Gnash 0.8.11dev, the GNU SWF Player. Copyright (C) 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License. For more information about Gnash, see http://www.gnu.org/software/gnash.
Compatible Shockwave Flash 10.1 r999.
Abilitato: Sì
Tipo MIME Descrizione Suffissi
application/x-shockwave-flash shockwave flash swf

Su epiphany non riesco a vedere i percorsi. Forse è un problema tra flashplayer di adobe e gnash....

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2069

scuola ha scritto:

La cartella $HOME/.mozilla/ non ha la cartella plugins.

OK creala e prova a copiare qui il file, non è detto che funzioni ma un tentativo lo farei.

Ritratto di scuola
scuola
(Newbie)
Offline
Newbie
Iscritto: 26/04/2014
Messaggi: 5

Fatto, ma non funziona.

Ho provato a installare flash non free con apt ma mi dice che il pacchetto non è disponibile: ho abilitato il repository non free ma forse ho sbagliato o mi sono perso qualcosa...

Ho installato il pacchetto flash non free .deb che si è installato regolarmente (ho visto che la versione è 11.02).
Con opera e iceweasel tutto ok (forse un po' più lento) ma con epiphany niente.

Quindi ho rimosso il pacchetto .deb (con flash 11.02) e ho copiato di nuovo libflashplayer (versione 10) in /usr/lib/mozilla/plugin.
Opera e iceweasel ok ma, come prima, niente epiphany.

Lascio tutto così perché non ci voglio perdere troppo tempo.

Grazie per tutti i consigli comunque utili e per la pazienza.