Problemino wireless

2 risposte [Ultimo contenuto]
Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Ciao,
sono riuscito nell'impresa di attivare la mia dlink g520+. Laughing

Il problema che si pone ora e' la criptazione wep.
<br /># iwlist wlan0 encryption<br />wlan0     3 key sizes : 40, 104, 232bits<br />          4 keys available :<br />                [1]: 0000-0000-0000-0000-0000-0000-00 (104 bits)<br />                [2]: off<br />                [3]: off<br />                [4]: off<br />          Current Transmit Key: [1]<br />          Security mode:restricted<br />

L'ap e' impostato con wep hex a 128 bit.
Malgrado i vari tentativi (anche con kwifimanager) non mi riesce di entrare in collegamento.
<br /># iwconfig<br />lo        no wireless extensions.<br /><br />eth0      no wireless extensions.<br /><br />wlan0     IEEE 802.11g+  ESSID:"miarete"  Nickname:"acx100 v0.2.0pre8"<br />          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0D:3F:0A:5E:46<br />          Bit Rate:1 Mb/s   Tx-Power:15 dBm   Sensitivity=1/3<br />          Retry min limit:7   RTS thr:off<br />          Encryption key:off<br />          Power Management:off<br />          Link Quality=53/100  Signal level=35/100  Noise level=0/100<br />          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0<br />          Tx excessive retries:0  Invalid misc:0   Missed beacon:0<br /><br />sit0      no wireless extensions.<br />
L'ap support 64/128/256 bit
ma sulla scheda si vedono solo 40/104/232. !?!

Qualche consiglio?
thanks Smile

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Fatto sta che riesco a collegarmi solo disattivando il wep.

Cercando di inserire la chiave wep con kwifimanager mi restituisce questo messaggio:
<br />Error for wireless request "Set Encode" (8B2A) :<br />    invalid argument "key".<br />
Sia questa in hex che in ascii.

Una wireless senza wep non mi sembra il massimo della sicurezza
Thinking
Sul ap ho impostato gli accessi solo a certi indirizzi mac.

Esiste quelche altro metodo per garantire un minimo di sicurezza?

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)