dipendenze skype

31 risposte [Ultimo contenuto]
Ritratto di pitstop
pitstop
(Junior)
Offline
Junior
Iscritto: 19/02/2014
Messaggi: 39

Ciao, ho scaricato dal sito di skype il pacchetto .deb per installarlo sul mio pc.
Mi sono posizionato nella directory dove era presente il pacchetto, ho dato il comando dpkg -i e apparentemente il programma si e' installato tant'e' che l'icona e' comparsa nel menu', pero' da terminale mi aveva scritto che c'erano dei problemi con le dipendenze, infatti il programma non si avvia..
Come posso risolvere il problema?

Grazie..

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Installando le dipendenze che ti ha detto di installare. Il seguente comando è utile quando si deve aggiustare un'installazione parziale:

apt-get --fix-broken install

Ritratto di pitstop
pitstop
(Junior)
Offline
Junior
Iscritto: 19/02/2014
Messaggi: 39

perdonami ma sono poco competente, sostanzialmente cosa e' successo? non ho installato delle dipendenze?
Come facevo a sapere quali erano da installare?
Il comando che mi hai specificato, installa quelle dipendenze?

Grazie..

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1124

pitstop ha scritto:

perdonami ma sono poco competente, sostanzialmente cosa e' successo? non ho installato delle dipendenze?


Si.

pitstop ha scritto:


Come facevo a sapere quali erano da installare?


Non ti preoccupare, il pacchetto le sa.

pitstop ha scritto:


Il comando che mi hai specificato, installa quelle dipendenze?


Si.

Debian. Be unique.

Ritratto di pitstop
pitstop
(Junior)
Offline
Junior
Iscritto: 19/02/2014
Messaggi: 39

Quindi la prossima volta devo dare anche quel comando?
Lo devo dare dopo il comando dpkg..?
Questo vale per tutti i pacchetti .deb?

Grazie..

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1124

Si. Vale per tutti i pacchetti che installi a mano, quindi non attraverso i repository. Nel pacchetto ci sono le dipendenze e per installarle basta dare il comando che ti hanno suggerito.

Debian. Be unique.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Il sistema di gestione dei pacchetti di Debian è molto potente, ma anche complesso. Puoi pensarlo come un sistema su più strati.

Al livello più basso c'è dpkg che opera sul singolo pacchetto: prende un file .deb, lo decomprime, smista i vari file nelle directory giuste e infine esegue gli script di configurazione.

Sopra c'è apt in tutte le sue diverse incarnazioni: apt-get, aptitude... Questo gestisce le relazioni tra i pacchetti: quale dipende da quale, in che repository si trova, se è già installato e se sì se lo è solo per soddisfare una dipendenza, ecc. Richiedendo ad apt di installare un pacchetto, questo si preoccupa di selezionare anche tutti i pacchetti da cui dipende e di controllare che non si generino conflitti (nel caso, propone una soluzione all'utente). Poi scarica dal repository giusto i file .deb di tutti i pacchetti da installare e alla fine chiama dpkg più volte per installarli uno per uno nell'ordine più consono.

Nel tuo caso, hai usato direttamente dpkg per installare a mano un pacchetto con delle dipendenze non soddisfatte. Ricorda: dpkg non può scaricare i pacchetti per te, quindi ha eseguito il comando che gli hai dato segnalandoti che il sistema rimaneva in uno stato incoerente. La cosa migliore, a questo punto, è usare apt-get con l'opzione --fix-broken che, come dice il nome stesso, cerca di riparare uno stato difettoso.

Spero che questa spiegazione faccia un po' di luce sul misterioso mondo dei pacchetti Debian. Wink

Ritratto di pitstop
pitstop
(Junior)
Offline
Junior
Iscritto: 19/02/2014
Messaggi: 39

Cavolo! eccezionale la tua dimostrazione di competenza! Applause Almeno mi hai fatto capire bene la meccanica della gestione dei pacchetti...ed e' fondamentale per poter fare le cose in modo corretto.
Quindi se ho ben capito, avessi utilizzato da subito apt-get lui avrebbe fatto tutto il lavoro necessario perche' ci avrebbe pensato lui a fare intervenire dpkg, mentre in questo caso con il comando --fix-broken vado a fare tutto quel lavoro di risoluzione delle dipendenze che non era stato svolto prima vero?
Per dipendenze, detto in modo spartano, si intende sostanzialmente di tutti quegli accessori ai quali deve appoggiarsi un programma per poter andare in esecuzione?

La spiegazione che mi hai dato mi ha colpito sai? Hai parlato di cose estremamente tecniche con una semplicita' e chiarezza che anche un incompetente come me non fatica a comprenderle...percortesia sapresti indicarmi una guida che spiega questi aspetti bene come li hai spiegati tu? Anche perche' non ho la pretesa che tu tutte le volte mi faccia una lezione... Wink

Grazie ancora...Ciao

Pero' adesso ho riprovato ad installare il pacchetto con dpkg e si e' installato subito correttamente, mentre l'altra volta no...prima pero' ho provato con apt ma non me lo installava...

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

Scusate, mi accodo perché anche io sto avendo problemi con le dipendenze di skype 4.2.0.13.

# dpkg -i skype-debian_4.2.0.13-1_i386.deb 
Selezionato il pacchetto skype non precedentemente selezionato.
(Lettura del database... 176665 file e directory attualmente installati.)
Preparing to unpack skype-debian_4.2.0.13-1_i386.deb ...
Unpacking skype (4.2.0.13-1) ...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
 skype dipende da libqt4-dbus (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-dbus non è installato.
 skype dipende da libqt4-network (>= 4:4.8.0); comunque:
  Il pacchetto libqt4-network:i386 non è installato.
 skype dipende da libqt4-xml (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-xml:i386 non è installato.
 skype dipende da libqtcore4 (>= 4:4.7.0~beta1); comunque:
  Il pacchetto libqtcore4:i386 non è installato.
 skype dipende da libqtgui4 (>= 4:4.8.0); comunque:
  Il pacchetto libqtgui4:i386 non è installato.
 skype dipende da libqtwebkit4 (>= 2.1.0~2011week13); comunque:
  Il pacchetto libqtwebkit4:i386 non è installato.
 skype dipende da libxss1; comunque:
  Il pacchetto libxss1:i386 non è installato.
 skype dipende da libxv1; comunque:
  Il pacchetto libxv1:i386 non è installato.
 skype dipende da libasound2-plugins; comunque:
 
dpkg: error processing package skype (--install):
 problemi con le dipendenze - lasciato non configurato
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Si sono verificati degli errori nell'elaborazione:
 skype
 
# apt-get --fix-broken install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libaudio2:i386 libavutil52:i386 libgsm1:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libjack-jackd2-0:i386 liblcms1:i386 libmng1:i386 libopenjpeg2:i386 libopus0:i386 liborc-0.4-0:i386 libqt4-dbus:i386
  libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386 libsamplerate0:i386
  libschroedinger-1.0-0:i386 libspeex1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libtheora0:i386 libva1:i386 libx264-133:i386
  libxss1:i386 libxt6:i386 libxv1:i386 libxvidcore4:i386
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  libaudio2:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 liblcms1:i386 libmng1:i386 liborc-0.4-0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
  libsqlite3-0:i386 libxss1:i386 libxt6:i386 libxv1:i386
Pacchetti suggeriti:
  nas:i386 libvisual-0.4-plugins:i386 gstreamer-codec-install:i386 gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms-utils:i386 libicu52:i386 qt4-qtconfig:i386
I seguenti pacchetti saranno RIMOSSI:
  skype:i386
I seguenti pacchetti NUOVI saranno installati:
  libaudio2:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 liblcms1:i386 libmng1:i386 liborc-0.4-0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
  libsqlite3-0:i386 libxss1:i386 libxt6:i386 libxv1:i386
0 aggiornati, 17 installati, 1 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/16,5 MB di archivi.
Dopo quest'operazione, verranno occupati 17,8 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 176813 file e directory attualmente installati.)
Removing skype (4.2.0.13-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Selezionato il pacchetto libsqlite3-0:i386 non precedentemente selezionato.
(Lettura del database... 176665 file e directory attualmente installati.)
Preparing to unpack .../libsqlite3-0_3.8.3.1-1_i386.deb ...
Unpacking libsqlite3-0:i386 (3.8.3.1-1) ...
Selezionato il pacchetto libxt6:i386 non precedentemente selezionato.
Preparing to unpack .../libxt6_1%3a1.1.4-1_i386.deb ...
Unpacking libxt6:i386 (1:1.1.4-1) ...
Selezionato il pacchetto libaudio2:i386 non precedentemente selezionato.
Preparing to unpack .../libaudio2_1.9.4-1_i386.deb ...
Unpacking libaudio2:i386 (1.9.4-1) ...
Selezionato il pacchetto libgstreamer0.10-0:i386 non precedentemente selezionato.
Preparing to unpack .../libgstreamer0.10-0_0.10.36-1.2_i386.deb ...
Unpacking libgstreamer0.10-0:i386 (0.10.36-1.2) ...
Selezionato il pacchetto liborc-0.4-0:i386 non precedentemente selezionato.
Preparing to unpack .../liborc-0.4-0_1%3a0.4.18-1_i386.deb ...
Unpacking liborc-0.4-0:i386 (1:0.4.18-1) ...
Selezionato il pacchetto libgstreamer-plugins-base0.10-0:i386 non precedentemente selezionato.
Preparing to unpack .../libgstreamer-plugins-base0.10-0_0.10.36-1.1_i386.deb ...
Unpacking libgstreamer-plugins-base0.10-0:i386 (0.10.36-1.1) ...
Selezionato il pacchetto liblcms1:i386 non precedentemente selezionato.
Preparing to unpack .../liblcms1_1.19.dfsg-1.2+b1_i386.deb ...
Unpacking liblcms1:i386 (1.19.dfsg-1.2+b1) ...
Selezionato il pacchetto libmng1:i386 non precedentemente selezionato.
Preparing to unpack .../libmng1_1.0.10-3_i386.deb ...
Unpacking libmng1:i386 (1.0.10-3) ...
Selezionato il pacchetto libqtcore4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtcore4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtcore4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqt4-xml:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-xml_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-xml:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtdbus4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtdbus4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtdbus4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqt4-network:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-network_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-network:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtgui4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtgui4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtgui4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtwebkit4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtwebkit4_2.2.1-7_i386.deb ...
Unpacking libqtwebkit4:i386 (2.2.1-7) ...
Selezionato il pacchetto libxss1:i386 non precedentemente selezionato.
Preparing to unpack .../libxss1_1%3a1.2.2-1_i386.deb ...
Unpacking libxss1:i386 (1:1.2.2-1) ...
Selezionato il pacchetto libxv1:i386 non precedentemente selezionato.
Preparing to unpack .../libxv1_2%3a1.0.10-1_i386.deb ...
Unpacking libxv1:i386 (2:1.0.10-1) ...
Selezionato il pacchetto libqt4-dbus:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-dbus_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-dbus:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Configurazione di libsqlite3-0:i386 (3.8.3.1-1)...
Configurazione di libxt6:i386 (1:1.1.4-1)...
Configurazione di libaudio2:i386 (1.9.4-1)...
Configurazione di libgstreamer0.10-0:i386 (0.10.36-1.2)...
Configurazione di liborc-0.4-0:i386 (1:0.4.18-1)...
Configurazione di libgstreamer-plugins-base0.10-0:i386 (0.10.36-1.1)...
Configurazione di liblcms1:i386 (1.19.dfsg-1.2+b1)...
Configurazione di libmng1:i386 (1.0.10-3)...
Configurazione di libqtcore4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqt4-xml:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtdbus4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqt4-network:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtgui4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtwebkit4:i386 (2.2.1-7)...
Configurazione di libxss1:i386 (1:1.2.2-1)...
Configurazione di libxv1:i386 (2:1.0.10-1)...
Configurazione di libqt4-dbus:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Processing triggers for libc-bin (2.17-97) ...

In sostanza skype è installato e disinstallato subito dopo.
Come posso risolvere questo problema?
Premetto che il sistema è già multiarch.
Grazie

PS: Giusto per curiosità: ma i comandi apt-get --fix-broken install e apt-get -f install fanno la stessa cosa?

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1124

Strano... prova a rimuovere i pacchetti inutili (tanto se servono ti verranno installati successivamente, fare un bell'update e reinstallare skype:

apt-get --purge -y autoremove
apt-get update
apt-get -y dist-upgrade
dpkg -i skype-debian_4.2.0.13-1_i386.deb
apt-get -f -y install

probabilmente hai qualche pacchetto in conflitto.

Ciao

Debian. Be unique.

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1106

# apt-get --purge -y autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
 
# apt-get update
.
.
.
(non riporto il testo per brevità)
 
# # apt-get -y dist-upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Eseguito
Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
  libjim0debian2
Usare "apt-get autoremove" per rimuoverlo.
I seguenti pacchetti NUOVI saranno installati:
  libjim0.74
I seguenti pacchetti saranno aggiornati:
  libservlet2.5-java python-crypto usb-modeswitch
3 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 645 kB di archivi.
Dopo quest'operazione, verranno occupati 681 kB di spazio su disco.
Scaricamento di:1 http://ftp.it.debian.org/debian/ testing/main libjim0.74 amd64 0.74-2 [120 kB]
Scaricamento di:2 http://ftp.it.debian.org/debian/ testing/main libservlet2.5-java all 6.0.39-1 [217 kB]
Scaricamento di:3 http://ftp.it.debian.org/debian/ testing/main python-crypto amd64 2.6.1-3+b1 [256 kB]                      
Scaricamento di:4 http://ftp.it.debian.org/debian/ testing/main usb-modeswitch amd64 2.1.0+repack0-1+b1 [53,1 kB]            
Recuperati 645 kB in 9s (66,5 kB/s)                                                                                          
Lettura dei changelog... Fatto
Selezionato il pacchetto libjim0.74:amd64 non precedentemente selezionato.
(Lettura del database... 176665 file e directory attualmente installati.)
Preparing to unpack .../libjim0.74_0.74-2_amd64.deb ...
Unpacking libjim0.74:amd64 (0.74-2) ...
Preparing to unpack .../libservlet2.5-java_6.0.39-1_all.deb ...
Unpacking libservlet2.5-java (6.0.39-1) over (6.0.37-1) ...
Preparing to unpack .../python-crypto_2.6.1-3+b1_amd64.deb ...
Unpacking python-crypto (2.6.1-3+b1) over (2.6.1-3) ...
Preparing to unpack .../usb-modeswitch_2.1.0+repack0-1+b1_amd64.deb ...
Unpacking usb-modeswitch (2.1.0+repack0-1+b1) over (2.1.0+repack0-1) ...
Processing triggers for man-db (2.6.6-1) ...
Configurazione di libjim0.74:amd64 (0.74-2)...
Configurazione di libservlet2.5-java (6.0.39-1)...
Configurazione di python-crypto (2.6.1-3+b1)...
Configurazione di usb-modeswitch (2.1.0+repack0-1+b1)...
Processing triggers for libc-bin (2.17-97) ...
 
# dpkg -i skype-debian_4.2.0.13-1_i386.deb
Selezionato il pacchetto skype non precedentemente selezionato.
(Lettura del database... 176671 file e directory attualmente installati.)
Preparing to unpack skype-debian_4.2.0.13-1_i386.deb ...
Unpacking skype (4.2.0.13-1) ...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
 skype dipende da libqt4-dbus (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-dbus non è installato.
 skype dipende da libqt4-network (>= 4:4.8.0); comunque:
  Il pacchetto libqt4-network:i386 non è installato.
 skype dipende da libqt4-xml (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-xml:i386 non è installato.
 skype dipende da libqtcore4 (>= 4:4.7.0~beta1); comunque:
  Il pacchetto libqtcore4:i386 non è installato.
 skype dipende da libqtgui4 (>= 4:4.8.0); comunque:
  Il pacchetto libqtgui4:i386 non è installato.
 skype dipende da libqtwebkit4 (>= 2.1.0~2011week13); comunque:
  Il pacchetto libqtwebkit4:i386 non è installato.
 skype dipende da libxss1; comunque:
  Il pacchetto libxss1:i386 non è installato.
 skype dipende da libxv1; comunque:
  Il pacchetto libxv1:i386 non è installato.
 skype dipende da libasound2-plugins; comunque:
 
dpkg: error processing package skype (--install):
 problemi con le dipendenze - lasciato non configurato
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Si sono verificati degli errori nell'elaborazione:
 skype
 
apt-get -f -y install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libaudio2:i386 libavutil52:i386 libgsm1:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libjack-jackd2-0:i386 libjim0debian2 liblcms1:i386 libmng1:i386 libopenjpeg2:i386 libopus0:i386 liborc-0.4-0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
  libsamplerate0:i386 libschroedinger-1.0-0:i386 libspeex1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libtheora0:i386
  libva1:i386 libx264-133:i386 libxss1:i386 libxt6:i386 libxv1:i386 libxvidcore4:i386
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  libaudio2:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 liblcms1:i386 libmng1:i386 liborc-0.4-0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
  libsqlite3-0:i386 libxss1:i386 libxt6:i386 libxv1:i386
Pacchetti suggeriti:
  nas:i386 libvisual-0.4-plugins:i386 gstreamer-codec-install:i386 gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms-utils:i386 libicu52:i386 qt4-qtconfig:i386
I seguenti pacchetti saranno RIMOSSI:
  skype:i386
I seguenti pacchetti NUOVI saranno installati:
  libaudio2:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 liblcms1:i386 libmng1:i386 liborc-0.4-0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
  libsqlite3-0:i386 libxss1:i386 libxt6:i386 libxv1:i386
0 aggiornati, 17 installati, 1 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 3440 kB/16,5 MB di archivi.
Dopo quest'operazione, verranno occupati 17,8 MB di spazio su disco.
Scaricamento di:1 http://ftp.it.debian.org/debian/ testing/main libxt6 i386 1:1.1.4-1 [201 kB]
Scaricamento di:2 http://ftp.it.debian.org/debian/ testing/main libaudio2 i386 1.9.4-1 [78,1 kB]
Scaricamento di:3 http://ftp.it.debian.org/debian/ testing/main libgstreamer0.10-0 i386 0.10.36-1.2 [1750 kB]
Scaricamento di:4 http://ftp.it.debian.org/debian/ testing/main liborc-0.4-0 i386 1:0.4.18-1 [142 kB]                        
Scaricamento di:5 http://ftp.it.debian.org/debian/ testing/main libgstreamer-plugins-base0.10-0 i386 0.10.36-1.1 [1014 kB]   
Scaricamento di:6 http://ftp.it.debian.org/debian/ testing/main libmng1 i386 1.0.10-3 [237 kB]                               
Scaricamento di:7 http://ftp.it.debian.org/debian/ testing/main libxss1 i386 1:1.2.2-1 [17,5 kB]                             
Recuperati 3440 kB in 22s (155 kB/s)                                                                                         
(Lettura del database... 176819 file e directory attualmente installati.)
Removing skype (4.2.0.13-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Selezionato il pacchetto libsqlite3-0:i386 non precedentemente selezionato.
(Lettura del database... 176671 file e directory attualmente installati.)
Preparing to unpack .../libsqlite3-0_3.8.3.1-1_i386.deb ...
Unpacking libsqlite3-0:i386 (3.8.3.1-1) ...
Selezionato il pacchetto libxt6:i386 non precedentemente selezionato.
Preparing to unpack .../libxt6_1%3a1.1.4-1_i386.deb ...
Unpacking libxt6:i386 (1:1.1.4-1) ...
Selezionato il pacchetto libaudio2:i386 non precedentemente selezionato.
Preparing to unpack .../libaudio2_1.9.4-1_i386.deb ...
Unpacking libaudio2:i386 (1.9.4-1) ...
Selezionato il pacchetto libgstreamer0.10-0:i386 non precedentemente selezionato.
Preparing to unpack .../libgstreamer0.10-0_0.10.36-1.2_i386.deb ...
Unpacking libgstreamer0.10-0:i386 (0.10.36-1.2) ...
Selezionato il pacchetto liborc-0.4-0:i386 non precedentemente selezionato.
Preparing to unpack .../liborc-0.4-0_1%3a0.4.18-1_i386.deb ...
Unpacking liborc-0.4-0:i386 (1:0.4.18-1) ...
Selezionato il pacchetto libgstreamer-plugins-base0.10-0:i386 non precedentemente selezionato.
Preparing to unpack .../libgstreamer-plugins-base0.10-0_0.10.36-1.1_i386.deb ...
Unpacking libgstreamer-plugins-base0.10-0:i386 (0.10.36-1.1) ...
Selezionato il pacchetto liblcms1:i386 non precedentemente selezionato.
Preparing to unpack .../liblcms1_1.19.dfsg-1.2+b1_i386.deb ...
Unpacking liblcms1:i386 (1.19.dfsg-1.2+b1) ...
Selezionato il pacchetto libmng1:i386 non precedentemente selezionato.
Preparing to unpack .../libmng1_1.0.10-3_i386.deb ...
Unpacking libmng1:i386 (1.0.10-3) ...
Selezionato il pacchetto libqtcore4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtcore4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtcore4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqt4-xml:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-xml_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-xml:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtdbus4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtdbus4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtdbus4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqt4-network:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-network_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-network:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtgui4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtgui4_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqtgui4:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Selezionato il pacchetto libqtwebkit4:i386 non precedentemente selezionato.
Preparing to unpack .../libqtwebkit4_2.2.1-7_i386.deb ...
Unpacking libqtwebkit4:i386 (2.2.1-7) ...
Selezionato il pacchetto libxss1:i386 non precedentemente selezionato.
Preparing to unpack .../libxss1_1%3a1.2.2-1_i386.deb ...
Unpacking libxss1:i386 (1:1.2.2-1) ...
Selezionato il pacchetto libxv1:i386 non precedentemente selezionato.
Preparing to unpack .../libxv1_2%3a1.0.10-1_i386.deb ...
Unpacking libxv1:i386 (2:1.0.10-1) ...
Selezionato il pacchetto libqt4-dbus:i386 non precedentemente selezionato.
Preparing to unpack .../libqt4-dbus_4%3a4.8.5+git209-g718fae5+dfsg-1_i386.deb ...
Unpacking libqt4-dbus:i386 (4:4.8.5+git209-g718fae5+dfsg-1) ...
Configurazione di libsqlite3-0:i386 (3.8.3.1-1)...
Configurazione di libxt6:i386 (1:1.1.4-1)...
Configurazione di libaudio2:i386 (1.9.4-1)...
Configurazione di libgstreamer0.10-0:i386 (0.10.36-1.2)...
Configurazione di liborc-0.4-0:i386 (1:0.4.18-1)...
Configurazione di libgstreamer-plugins-base0.10-0:i386 (0.10.36-1.1)...
Configurazione di liblcms1:i386 (1.19.dfsg-1.2+b1)...
Configurazione di libmng1:i386 (1.0.10-3)...
Configurazione di libqtcore4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqt4-xml:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtdbus4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqt4-network:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtgui4:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Configurazione di libqtwebkit4:i386 (2.2.1-7)...
Configurazione di libxss1:i386 (1:1.2.2-1)...
Configurazione di libxv1:i386 (2:1.0.10-1)...
Configurazione di libqt4-dbus:i386 (4:4.8.5+git209-g718fae5+dfsg-1)...
Processing triggers for libc-bin (2.17-97) ...
root@debian-acer:/home/claudio/Desktop# skype
bash: skype: command not found

come al solito

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde