Problemi con Vfat e Terminal [Problemi! Help me!]

7 risposte [Ultimo contenuto]
Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

1) ho ricompilato il kernel ed è andato tutto ok il sistema parte tranquillamente, l'unico problema è che non si vedono tutte le scritte iniziali, si vede solamente dal login in poi!

2) ho un'altra partizione fat32 e ho dato i permessi di scrittura, lettura, e montaggio a tutti i gli utenti. la partizione viene montata in automatico. il problema sta nel fatto che viene montata da root e non da user, per poterla utilizzare devo prima smontarla da root e rimontarla da user!

grazie anticipatamente

illoto

illoto --> :pint: --> :-o

Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

Device Drivers ---> Chacaterd Devices ---> Support for console on virtual terminal è attivo ma nn si vede nulla lo stesso!

illoto --> :pint: --> :-o

Ritratto di Antonio
Antonio
(Geek)
Offline
Geek
Iscritto: 13/09/2004
Messaggi: 162

Hai attivato il driver vesa staticamente (con *, non con M)? Se non hai quello non va il frame buffer.

Come soluzione temporanea puoi togliere in /boot/grub/menu.lst alla riga del kernel l'opzione vga=numero, così vedrai di nuovo le scritte anche se grosse.

Ti posto le varie voci da attivare nel kernel:
Graphics support --->
[*] Support for frame buffer devices
<*> VESA VGA graphics support
Console display driver support --->
[*] Video mode selection support
<*> Framebuffer Console support

Se non sbaglio dovrebbe bastare.

Ritratto di cHroMe
cHroMe
(Geek)
Offline
Geek
Iscritto: 10/09/2004
Messaggi: 179

per il problema della partizione: hai messo umask=000 nella colonna delle opzioni di fstab?

«Faceva caldo, la notte che bruciammo Chrome....»
"Burning Chrome" William Gibson

Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

questo è il mio fstab:

# /etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda5 /mnt/data vfat rw,users,auto 0 0
/dev/hda1 /mnt/windows vfat rw,users,noauto 0 0

va bene?

illoto --> :pint: --> :-o