Problema aggiornameti

3 risposte [Ultimo contenuto]
Ritratto di albius
albius
(Junior)
Offline
Junior
Iscritto: 19/06/2009
Messaggi: 7

Ciao a tutti, non sono molto pratico di debian "sono una schiappa" , ho fatto una installazione su un server casalingo per prova e ci stavo lavorando. Ho installato con il primo cd che si scarica dato che volevo solo la shell. ho installato solo ssh per capire meglio come lavora. Ho provato dare il comando :

:/etc/apt# apt-get upgrade
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

e come se non leggesse i repository, ho provato anche installare :

apt-get htop mi dice che non lo trova mi date qualche dritta per favore .. Grazie a tutti

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

apt-get update aggiorna la lista dei pacchetti
apt-get upgrade aggiorna i pacchetti aggiornabili
apt-get install htop ti installa il pacchetto htop

ciao

Ritratto di olorian
olorian
(Junior)
Offline
Junior
Iscritto: 24/05/2009
Messaggi: 18

attenzione #1: do per scontato che la tua versione è la 5.0 (lenny), stable; se ne hai un'altra i repository che ho indicato probabilmente non fanno al caso tuo, ma non è difficile trovare quelli adatti alla tua versione

#2: naturalmente per usare i repository è necessario che tu abbia già impostato la connessione ad internet

se il "repository" è il cd di installazione, è normale che dando "apt-get upgrade" [che serve ad aggiornare i pacchetti installati alle versioni più recenti disponibili] non venga aggiornato nulla, perché i pacchetti sul cd sono sempre gli stessi..
per aggiornare i pacchetti installati devi modificare il file /etc/apt/sources.list commentando la linea del cd ed aggiungendovi quelle dei repository ufficiali o di altri che ti servissero, ad esempio così:
CONTENUTO DI SOURCES.LIST<br /><i>[il cd commentato:]</i><br /># deb cdrom:[Debian GNU/Linux LennyBeta2 _Lenny_ - Official Beta amd64 CD Binary-1 20080607-19:55]/ lenny main <br /><br /><i>i repository ufficiali</i><br />deb http://security.debian.org/ lenny/updates main <br />deb-src http://security.debian.org/ lenny/updates main <br />deb-src ftp://ftp.it.debian.org/debian/ lenny main contrib non-free <br />deb http://ftp.it.debian.org/debian/ lenny main contrib non-free


una volta aggiornato il file puoi dare apt-get update per aggiornare l'elenco dei pacchetti; in questo modo dando nuovamente l'upgrade i pacchetti saranno aggiornati

ad ogni modo tutto questo non è di per sé indispensabile per installare un nuovo pacchetto.. essendo se htop è presente sul cd, l'apt-get install htop già suggerito basta e avanza -)
la modifica dei repository è più una comodità, per avere gli aggiornamenti [se hai Debian 5.0 (Lenny) le versioni dei programmi non cambiano, quindi non si corrono nemmeno i relativi rischi], e soprattutto perché se hai un solo cd di installazione facilmente ti potrebbe capitare di voler installare un pacchetto che non vi è contenuto..

Ritratto di albius
albius
(Junior)
Offline
Junior
Iscritto: 19/06/2009
Messaggi: 7

ho scaricato l'ultimo cd ma ora vedo /etc/apt/sources.list che ce dentro . Funziona tutto bene , semplice da usare "mi avevano che era una specie di mostro da usare". Grazie e gentilissimo mo ci guardo.