https

3 risposte [Ultimo contenuto]
Ritratto di mandrux
mandrux
(Junior)
Offline
Junior
Iscritto: 16/06/2007
Messaggi: 20

salve a tutti.
a dura fatica sono riuscito finalmente ad avere un apache webserver bello funzionante ( it´s work!!).sia in locale che in remoto.
bene il problema sorge che quando digito :
https://miosubdominio.dyndns.com dal computer client
questo mi restituisce la pagina di configurazione del router.
probabilmente solo succede nella mia lan, ma vorrei essere sicuro
di avere un server ben protetto (sono alle prime armi,scusate)

inoltre in un futuro vorrei controllare il server da remoto,
avete qualche consiglio?
grazie in anticipo

Ritratto di ferdybassi
ferdybassi
(Geek)
Offline
Geek
Iscritto: 25/10/2006
Messaggi: 195

Hai installato e configurato il supporto SSL per Apache?
In questaguida c'è una sezione su SSL:
http://guide.debianizzati.org/index.php/LAMP:_Linux%2C_Apache%2C_MySQL_e_PHP

Per il router, prova a vedere se c'è un'opzione per abilitare l'amministrazione dai soli PC della lan.

Ciao ciao

Ritratto di nibbio972
nibbio972
(Geek)
Offline
Geek
Iscritto: 28/05/2007
Messaggi: 124

Per fare in modo che non ti visualizzi la pagina di conf del router, devi disabilitare l'amministrazione remota del router, cioè esterna alla lan, ma devi anche abilitare il port forwarding almeno della porta 80 (http)sull'indirizzo del server. In quasi tutti i router esiste questa possibilità.
Se il tuo server dovrà essere anche abilitato come ftp server, dovrai inoltare anche la porta 21. Per un server mail la 25.
Ciao

Ritratto di mandrux
mandrux
(Junior)
Offline
Junior
Iscritto: 16/06/2007
Messaggi: 20

grazie innanzitutto per le immediate risposte.
il port forwarding per il porto 80 e´ fatto .
come disattivare il controllo da remoto invece non ne
idea di come si faccia e neppure se questa opzione sia possibile
nel apparecchio in questione.
un trucchetto che mi e´ servito parecchio e'quello di
andare su google>strumenti per lingue>traduci pagina>
https://miosubdominio.dyndns.com e vedere con piacere
che il "traduttore" non riesce a tradurre la pagina rimandandomi
al vero sito http://miosubdominio.com (testato oltretutto in
mancanza di un amic@ connessi per verificare se il server risponde
o no.
il modulo ssl invece e´ attivo anche se non ho avuto ancora il tempo
di testarlo.
che ne pensate invece di webmin?