MTU e NAT

8 risposte [Ultimo contenuto]
Ritratto di jordan83
jordan83
(Monster)
Offline
Monster
Iscritto: 10/09/2004
Messaggi: 267

Ciao!

Sto realizzando un piccolo server casalingo per un amico.

Il pc è un Pentium 133 (o 166) con 44Mb di ram.

Accede a internet via adsl con un D-Link dsl-300t configurato come router pppoa.
Il server fa da gateway per ora oer un solo pc win xp.

Leggendo qua e là, io non ho l'adsl, ho scoperto che bisogna regolare il valore MTU per far funzionare bene la condivisione internet.

Era impostato a 1492 e internet era bloccato (nel senso che il server viaggiava benissimo, mentre il client ci metteva 2 minuti a caricare una pagina.)

Ho abbassato a 1400 e ancora nada.

Portato a 920 andava già bene, ma il valore finale che abbiamo impostato è 800. Sul server funziona anche mldonkey e, dopo che l'ho avviato, ho notato che il client carica perfettamente alcuni siti mentre altri li da per non reperibili.

Ora mi chiedo, devo abbassare ancora il valore MTU, o lo devo alzare?
Intorno a che valori devo attestarmi? Thinking

Se potete darmi una mano, grazie! Wink

A presto

"Se avessimo tutti le stesse opinioni non ci sarebbero le corse dei cavalli." G.B.Shaw

Ritratto di jordan83
jordan83
(Monster)
Offline
Monster
Iscritto: 10/09/2004
Messaggi: 267

Ciao,

grazie delle ottime segnalazioni. Mi hai chiarito alcuni dubbi di indubbia rievanza, come ad esempio il significato di MTU.

Ora vorrei capire se il deperimento del server sia da dare all MTU, a mldonkey o magari al modem stesso.

Tra l'altro ho appena scoperto che stamattina il mio amico non apriva più nessuna pagina web.

Forse è mldonkey, mi sembra di aver letto che ha un bug che gli fa mangiare memoria e processore a nastro.

Qualcuno lo usa e mi può dare le proprie impressioni?

Grazie ancora, ciao!!

"Se avessimo tutti le stesse opinioni non ci sarebbero le corse dei cavalli." G.B.Shaw

Ritratto di jordan83
jordan83
(Monster)
Offline
Monster
Iscritto: 10/09/2004
Messaggi: 267

Il server è definitivamente scoppiato.
Mentre ieri lavorava bene senza mldonkey, oggi non fa neppure quello.

A sto punto temo che il problema sia o il modem, che tuttavia è nuovo, oppure il server stesso, ben vecchiotto. 40 Mb di ram forse son pochi, eppure credevo che ce la facesse almeno a fare da gateway. Non so che pensare, ci avevo impiegato moltissimo tempo a realizzarlo.

Se ne riparlerà dopo la fiera di Pordenone, dove cercheremo hw più performante.

Comunque grazie del supporto. Big Grin

Che dire, alla prossima.

"Se avessimo tutti le stesse opinioni non ci sarebbero le corse dei cavalli." G.B.Shaw

Ritratto di jordan83
jordan83
(Monster)
Offline
Monster
Iscritto: 10/09/2004
Messaggi: 267

ehmbè, effettivamente chiedevo un attimo troppo.

Ci vuole più "sostanza". 8-)

Ciao!

"Se avessimo tutti le stesse opinioni non ci sarebbero le corse dei cavalli." G.B.Shaw