Montaggio HD di Windows

7 risposte [Ultimo contenuto]
Ritratto di ServerDrop
ServerDrop
(Newbie)
Offline
Newbie
Iscritto: 18/04/2007
Messaggi: 3

Salve a tutti voi. Ho da poco installato Debian e devo dire che il primo impatto è stato molto piacevole. Debian è montato in una partizione e in un'altra c'è Windows. Non vi spaventate, in Windows ci tengo solo i backup Big Grin

Quello che non riesco a fare è montare l'HD di Windows. Ho provato in duecentomila modi ma non riesco.

Spero che possiate aiutarmi, 'alve.

Ritratto di rufus
rufus
(Monster)
Offline
Monster
Iscritto: 06/04/2005
Messaggi: 255

Quote:

ServerDrop ha scritto:
Salve a tutti voi. Ho da poco installato Debian e devo dire che il primo impatto è stato molto piacevole. Debian è montato in una partizione e in un'altra c'è Windows. Non vi spaventate, in Windows ci tengo solo i backup Big Grin

Quello che non riesco a fare è montare l'HD di Windows. Ho provato in duecentomila modi ma non riesco.

Spero che possiate aiutarmi, 'alve.

Ciao, credo che posso parlare a nome di tutti, non ti preoccupare noi non ci spaventiamo.
La nostra paura invece è quella che tu non ci dici molto sul sistema windows caricato. Cioè in primis ci devi dire che filesystem ha il tuo windows. Poi possiamo aiutarti a capire come si monta un filesystem

Laughing Laughing

Ritratto di kalos
kalos
(Collaboratore)
Offline
Collaboratore
Iscritto: 26/01/2005
Messaggi: 710

....forse aprendo il forno a microonde..

If you haven't tried Debian lately, this would be a good time.

deb lenny/sid
linux user 384443 http://counter.li.org/
linux nelle scuole, firma la petizione

Ritratto di gabry
gabry
(Monster)
Offline
Monster
Iscritto: 29/10/2006
Messaggi: 395

io nel file /etc/fstab ho la seguente riga:
<br />/dev/sda1       /mnt/windows    auto    rw,user,noauto  0       0<br />
ora non so quale sia la nomenclatura dei dispositivi nel tuo pc...i miei dischi si chiamano sda1, sd2, sda3, etc...perchè ho un hard disk sata. E' probabile che te debba mettere hda[numero].

ho impostato l'utente "normale" (cioè non root) come proprietario della cartella /mnt/windows:
<br />gabry@zdesk:/mnt$ ls -l<br />totale 8<br />drwxr-xr-x 2 gabry gabry 4096 2006-11-29 21:58 discone<br />drwxr-xr-x 2 gabry gabry 4096 2007-04-18 21:17 windows<br />
e montando me lo trova senza problemi.
<br />mount /mnt/windows<br />

questo funge se windows ha una partizione fat (16 o 32); se invece è partizionato ntfs, potresti avere dei problemi.

ciao ciao

"Non e' la legge che decide cosa e' giusto e cosa e' sbagliato"
R. Stallman

Ritratto di samiel
samiel
(Monster)
Offline
Monster
Iscritto: 20/12/2005
Messaggi: 496

Tu hai messo:

=================
rw,user,noauto 0 0
=================

Io invece preferisco:

=================
defaults 0 0
=================

Così infatti la partizione è montata in sola lettura
(non mi interessa scrivere su ntfs), la monta root
(considera che il montaggio è cosa del tutto diversa
dalla possibilità degli utenti di scriverci sopra)
e infine, invece di noauto, viene montata
automaticamente all'avvio

M.

linux user no.: 353546
public key at http://keyserver.linux.it

Ritratto di ServerDrop
ServerDrop
(Newbie)
Offline
Newbie
Iscritto: 18/04/2007
Messaggi: 3

Grazie, ho risolto installandomi ntfs-3g e dando il comando:

ntfs-3g /dev/sda1 /mnt/

grazie comunque a tutti.

Ritratto di pistolinux
pistolinux
(Monster)
Offline
Monster
Iscritto: 05/12/2005
Messaggi: 430

/dev/sda1       /mnt        ntfs-3g noauto,silent,users,umask=0,locale=it_IT.utf8   0    0
se metti questa riga nel file /etc/fstab ti levi quasiasi pensiero... Wink

mess with the best, Love Struck
die like the rest. :cry:

Ritratto di ServerDrop
ServerDrop
(Newbie)
Offline
Newbie
Iscritto: 18/04/2007
Messaggi: 3

Quote:

pistolinux ha scritto:
/dev/sda1       /mnt        ntfs-3g noauto,silent,users,umask=0,locale=it_IT.utf8   0    0
se metti questa riga nel file /etc/fstab ti levi quasiasi pensiero... Wink

Molte grazie Smile