Firma Amavis-new

67 risposte [Ultimo contenuto]
Ritratto di Ricca
Ricca
(Junior)
Offline
Junior
Iscritto: 10/01/2007
Messaggi: 45

Ciao a tutti

in questi giorni ho configurato un server mail con postfix+amavis-new e tutto sembra funzionare correttamente.
Ora vorrei che tutte le mail che il server accetta di inviare dopo la scansione con amavis riportassero una dicitura tipo "Antivirus vers.xxx ultimo aggior. xxxxxxx" o qualcosa del genere....

Qualcuno sa se è possibile e magari come fare.. ? Wink

Ciao

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

afaik è il comportamento di default.

>> X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at lalunanera.com

e io ci ho fatto niet

sicuro che passino per amavis?
su che parametri basi la tesi che funzioni tutto ben?

Ritratto di Ricca
Ricca
(Junior)
Offline
Junior
Iscritto: 10/01/2007
Messaggi: 45

Ciao

ho provato a fare il test con il file che ho trovato in questo sito

http://www.eicar.org/

ed in mail log trovo

Quote:

Apr 18 09:40:30 kwserver amavis[2315]: (02315-01) Blocked BANNED (multipart/mixed | application/zip,.zip,eicarcom2.zip | .zip,eicar_com.zip | .asc,eicar.com), quarantine: banned-Sz1r7LfaNzCZ, Message-ID: <4625CB65.4070309@keywordpc.it>, mail_id: Sz1r7LfaNzCZ, Hits: -, 4179 ms

mentre se non metto il file scaricato dal sito sopra trovo

Quote:

Apr 18 09:40:39 kwserver amavis[2316]: (02316-01) Passed CLEAN, [192.168.0.240], Message-ID: <4625CB76.6000109@keywordpc.it>, mail_id: JkWnXAhpRu9e, Hits: -, queued_as: DA2F63347A2, 226 ms

Altre prove che posso fare?

Ritratto di Ricca
Ricca
(Junior)
Offline
Junior
Iscritto: 10/01/2007
Messaggi: 45

Da quello che sono riuscito a capire dovrebbero bastare

Quote:

# Add X-Virus-Scanned header field to mail?
$X_HEADER_TAG = 'X-Virus-Scanned'; # (default: 'X-Virus-Scanned')

# Set to empty to add no header field # (dflt "$myproduct_name at $mydomain")
# $X_HEADER_LINE = "$myproduct_name at $mydomain";
# $X_HEADER_LINE = "by $myproduct_name using ClamAV at $mydomain";
$X_HEADER_LINE = "$myproduct_name $myversion_id ($myversion_date) at $mydomain";

in /etc/amavid.conf per "firmare le scansioni", ma contiuna a non funzionare.
Qualcuno sa se bisogna configurare qualche altra cosa?

Ciao